poj 2506Tiling 大数

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9971 Accepted: 4681

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

import java.io.*;  
import java.math.BigInteger;  
import java.util.*;  
  
public class Main  
{  
    public static void main(String args[])  
    {  
        Scanner cin = new Scanner(System.in); 
        int n;
        BigInteger a[] = new BigInteger[255];  
        while(cin.hasNext())  
        {  
        	a[0] = BigInteger.valueOf(1);
            a[1] = BigInteger.valueOf(1);
            a[2] = BigInteger.valueOf(3);
            n = cin.nextInt();
            for(int i = 3; i <= n; ++i)  
                a[i] = a[i - 1].add(a[i - 2]).add(a[i - 2]);  
            System.out.println(a[n]);  
        }  
    }  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值