PAT 乙级 1041. 考试座位号(15) Java版

每个PAT考生在参加考试时都会被分配两个座位号,一个是试机座位,一个是考试座位。正常情况下,考生在入场时先得到试机座位号码,入座进入试机状态后,系统会显示该考生的考试座位号码,考试时考生需要换到考试座位就座。但有些考生迟到了,试机已经结束,他们只能拿着领到的试机座位号码求助于你,从后台查出他们的考试座位号码。

输入格式:

输入第一行给出一个正整数N(<=1000),随后N行,每行给出一个考生的信息:“准考证号 试机座位号 考试座位号”。其中准考证号由14位数字组成,座位从1到N编号。输入保证每个人的准考证号都不同,并且任何时候都不会把两个人分配到同一个座位上。

考生信息之后,给出一个正整数M(<=N),随后一行中给出M个待查询的试机座位号码,以空格分隔。

输出格式:

对应每个需要查询的试机座位号码,在一行中输出对应考生的准考证号和考试座位号码,中间用1个空格分隔。

输入样例:

4
10120150912233 2 4
10120150912119 4 1
10120150912126 1 3
10120150912002 3 2
2
3 4

输出样例:

10120150912002 2
10120150912119 1
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {

		Scanner in = new Scanner(System.in);
		int n = in.nextInt();
		Student[] students = new Student[n];
		for (int i = 0; i < n; i++) {
			students[i] = new Student(in.next(), in.next(), in.next());
		}
		
		int m = in.nextInt();
		for (int i = 0; i < m; i++) {
			String findTestSite = in.next();
			
			for (int j = 0; j < n; j++) {
				if (students[j].testSite.equals(findTestSite)) {
					System.out.println(students[j].id + " " + students[j].correctSite);
				}
			}
		}
		in.close();
	}

}

class Student {
	String id;
	String testSite;
	String correctSite;
	
	public Student(String id, String testSite, String correctSite) {
		this.id = id;
		this.testSite = testSite;
		this.correctSite = correctSite;
	}
}

对输入方式优化了一下,用Scanner读输入用时太长,改了一下输入方式

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {

	public static void main(String[] args) throws IOException{
		BufferedReader bufferedReader = new BufferedReader(new InputStreamReader(System.in));
		int n = Integer.parseInt(bufferedReader.readLine());
		Student[] students = new Student[n];
		for (int i = 0; i < n; i++) {
			String[] strings = bufferedReader.readLine().split(" ");
			students[i] = new Student(strings[0], strings[1], strings[2]);
		}
		
		int m = Integer.parseInt(bufferedReader.readLine());
		String[] test = bufferedReader.readLine().split(" ");
		for (int i = 0; i < m; i++) {
			String findTestSite = test[i];
			
			for (int j = 0; j < n; j++) {
				if (students[j].testSite.equals(findTestSite)) {
					System.out.println(students[j].id + " " + students[j].correctSite);
				}
			}
		}
		bufferedReader.close();
	}

}

class Student {
	String id;
	String testSite;
	String correctSite;
	
	public Student(String id, String testSite, String correctSite) {
		this.id = id;
		this.testSite = testSite;
		this.correctSite = correctSite;
	}
}
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值