HDU 5162

Jump and Jump...

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1219    Accepted Submission(s): 613


Problem Description
There are  n  kids and they want to know who can jump the farthest. For each kid, he can jump three times and the distance he jumps is maximum distance amount all the three jump. For example, if the distance of each jump is (10, 30, 20), then the farthest distance he can jump is 30. Given the distance for each jump of the kids, you should find the rank of each kid.
 

Input
There are multiple test cases. The first line of input contains an integer  T (1T100) , indicating the number of test cases. For each test case: The first line contains an integer  n (2n3) , indicating the number of kids. For the next  n  lines, each line contains three integers  ai,bi  and  ci  ( 1ai,bi,ci,300 ), indicating the distance for each jump of the  i -th kid. It's guaranteed that the final rank of each kid won't be the same (ie. the farthest distance each kid can jump won't be the same).
 

Output
For each test case, you should output a single line contain  n  integers, separated by one space. The  i -th integer indicating the rank of  i -th kid.
 

Sample Input
  
  
2 3 10 10 10 10 20 30 10 10 20 2 3 4 1 1 2 1
 

Sample Output
  
  
3 1 2 1 2
/**
此题不难,但是刚看到的时候给我一种无从下手的感觉,此处总结一下
首先要抽取真正有用的数据,那就是每个人跳的最远距离,然后在循环
中进行统计就可以了,当时一直想用set做,但思路并不清晰,所以碰到
题还是要老老实实的采取最常规的解题方法!!!
*/
#include<stdio.h>
#include<algorithm>
#include<string.h>

using namespace std;

int opt[1000];
int ans[1000];

int max3(int a,int b,int c)
{
    return max(max(a,b),c);
}

int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        int n,a,b,c;
        scanf("%d",&n);
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            opt[i] = max3(a,b,c);
        }
        memset(ans,0,sizeof(ans));
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
            {
                if(opt[j] > opt[i])
                    ans[i]++;
            }
        printf("%d",ans[0]+1);
        for(int i = 1; i < n; i++)
            printf(" %d",ans[i]+1);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值