HDU 1016 素数环

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34394    Accepted Submission(s): 15216


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
/**
在朋友和学长的帮助下总算解决了这道题,都说是回溯法,可我依然
分不清深搜和回溯的差别,此题有待进一步分析。待续。。。。。。。
*/
#include<stdio.h>
#include<string.h>

int n;
int vis[30];
int a[30];
int count = 0;

bool is_prime(int n)
{
    for(int i = 2; i*i <= n; i++)
        if(n%i == 0)
            return false;
    return true;
}

void dfs(int cur)
{
    if(cur == n && is_prime(a[0]+a[n-1]))///递归的边界条件,当最后一个位置放好的时候递归结束,由于是环,需判断首尾是否满足条件
    {
        printf("%d",a[0]);
        for(int i = 1; i < n; i++)
            printf(" %d",a[i]);
        printf("\n");
    }
    else for(int i = 2; i <= n; i++)///所有的可放元素
        {
            if(!vis[i] && is_prime(i+a[cur-1]))///判断当前元素是否满足条件
            {
                a[cur] = i;
                vis[i] = 1;///用过的元素标记一下
                dfs(cur+1);
                vis[i] = 0;///回溯的时候还原现场
            }
        }
}

int main()
{
    while(~scanf("%d",&n))
    {
        if(n%2!=0)
        {
            printf("Case %d:\n\n",++count);
            continue;
        }
        else
            printf("Case %d:\n",++count);
        a[0] = 1;
        memset(vis,0,sizeof(vis));
        dfs(1);
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值