1200 To and Fro

To and Fro

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 18
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.

Input

There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.

Output

Each input set should generate one line of output, giving the original plaintext message, with no spaces.

Sample Input

5
toioynnkpheleaigshareconhtomesnlewx
3
ttyohhieneesiaabss
0

Sample Output

theresnoplacelikehomeonasnowynightx
thisistheeasyoneab

题意:

给出一个数字,一个字符串,把字符串按从左到右,然后下一行从右到左的顺序存放在宽度为所给数字的矩阵中,如果有不足矩形的情况,就把当前位置添上字符 x ,然后输出的时候按列输出......


这个题,比较直接的方法就是模拟那个过程,然后按要求输出.....貌似有简单的方法,可惜现在学的太少....慢慢学吧!


#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
	char a,x[1005],y[205][205];
	int i,j,k,n,len,h,ok;
	while(scanf("%d",&n),n)
	{
		getchar();k=h=0;
		memset(x,0,sizeof(x));
		memset(y,0,sizeof(y));
		gets(x);len=strlen(x);
		for(i=0;x[k]!=0;++i)
		{
			for(j=0;j<n&&x[k]!=0;++j)//从左到右
			{
				y[i][j]=x[k];
				++k;
			}
			++i;
			for(j=n-1;j>=0&&x[k]!=0;--j)//从右到左
			{
				y[i][j]=x[k];
				++k;
			}
		}
		h=ceil(len*1.0/n);//判断矩阵几行.....
		for(i=0;i<n;++i)
		{
			for(j=0;j<h;++j)
			{
				if(y[j][i]!=0)
				{
					printf("%c",y[j][i]);
				}
				else
				{
					printf("x");
				}
			}
		}
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值