3620 Avoid The Lakes【dfs】

Avoid The Lakes
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6947 Accepted: 3691

Description

Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ K ≤ N × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

Input

* Line 1: Three space-separated integers: NM, and K
* Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

Output

* Line 1: The number of cells that the largest lake contains. 

Sample Input

3 4 5
3 2
2 2
3 1
2 3
1 1

Sample Output

4


题意:

给出三个数,前两个限定的是一个区域的宽和高,也就是矩阵的行和列,后一个代表有几个特殊点,后面对应的是点的坐标,规定,前后左右相邻的特殊点,算是一个集合,求出在这个范围内,元素最多的集合内有多少元素...


这个题是比较简单的 dfs 题目,只要用递归多次调用,加上特殊处理,以及统计个数的条件,不难求出答案,主要是理解 dfs 的工作原理...


#include<stdio.h>
#include<string.h>
int x[105][105],n,m,t,sum,max;
void dfs(int a,int b)
{
	if(a<0||a>n||b<0||b>m)//越界
	{
		return;
	}
	if(x[a][b]==0)//不是需要的点
	{
		return;
	}
	++sum;//在运行的时候统计....
	x[a][b]=0;
	dfs(a+1,b);//对前后左右进行搜索判断
	dfs(a-1,b);
	dfs(a,b+1);
	dfs(a,b-1);
}
int main()
{
	int i,j,a,b;
	while(~scanf("%d%d%d",&n,&m,&t))
	{
		memset(x,0,sizeof(x));
		for(i=0;i<t;++i)
		{
			scanf("%d%d",&a,&b);
			x[a][b]=1;//标记在二维数组上
		}
		max=sum=0;
		for(i=0;i<=n;++i)
		{
			for(j=0;j<=m;++j)
			{
				if(x[i][j]==1)//查找和运算
				{
					dfs(i,j);
					if(sum>max)
					{
						max=sum;//更新最大值
					}
					sum=0;
				}
			}
		}
		printf("%d\n",max);//输出
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值