poj 1218&&hdu 1337 The Drunk Jailer【简单模拟】

The Drunk Jailer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1394    Accepted Submission(s): 1124


Problem Description
A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked.
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey, and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the hall locking every other cell (cells 2, 4, 6, …). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, …). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He repeats this for n rounds, takes a final drink, and passes out.

Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape.

Given the number of cells, determine how many prisoners escape jail.
 

Input
The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n.
 

Output
For each line, you must print out the number of prisoners that escape when the prison has n cells.
 

Sample Input
  
  
2 5 100
 

Sample Output
  
  
2 10
 

题意:有n 个房子,编号1-n,刚开始门锁着,然后有个人会进行n次操作,第一次操作,是2,4,6,8,10.....第二次是 3,6,9,12.....

每次操作会改变门的状态,,让你求出,操作完成后,有多少门是开着的


个人没什么好办法,简单的模拟吧,就像之前一个简单的开灯关灯问题....


#include<stdio.h>
#include<string.h>
int main()
{
	int t,x[105],n;
	scanf("%d",&t);
	while(t--)
	{
		memset(x,0,sizeof(x));
		scanf("%d",&n);
		for(int i=1;i<=n;++i)//多少次操作
		{
			for(int j=2;j*i<=n;++j)//对应操作的门的编号.
			{
				x[i*j]=!x[i*j];
			}
		}
		int cnt=0;
		for(int i=1;i<=n;++i)//查找统计....
		{
			if(!x[i])
			{
				++cnt;
			}
		}
		printf("%d\n",cnt);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值