3665 Seaside【floyd】

Seaside

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1362    Accepted Submission(s): 977


Problem Description
XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.
 

Input
There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers S Mi and L Mi, which means that the distance between the i-th town and the S Mi town is L Mi.
 

Output
Each case takes one line, print the shortest length that XiaoY reach seaside.
 

Sample Input
  
  
5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1
 

Sample Output
  
  
2

题意:

有个人想去海边的城市,有的城市临海,有的不临海,给出每个城市和其他城市之间的道路和距离,让你找一条最短的路径到达海边的城市。

题目的范围比较小,数据量不大,完全可以floyd 算法简单解决,不过有个特殊的地方是,每个城市都要事先标记一下,这个城市是否临海,只有在临海的时候才更新最短的路径。


#include<stdio.h>
#include<string.h>
#define min(a,b) (a<b?a:b)
#define inf 0x3f3f3f3f
using namespace std;
int map[205][205],n,m;
bool x[105];
void floyd()
{
    for(int k=0;k<n;++k)
    {
    	for(int i=0;i<n;++i)
    	{
    		for(int j=0;j<n;++j)
    		{
    			map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
			}
		}
	}
}

int main()
{
	//freopen("shuju.txt","r",stdin);
	int i,j;
    while(~scanf("%d",&n))
    {
        memset(map,inf,sizeof(map));
        memset(x,0,sizeof(x));
        for(i=0,j=0;i<n;++i,++j)
        {
        	map[i][j]=0;//自身到自身距离 0  
		}
        int a,b;
        for(i=0;i<n;++i)
        {
            scanf("%d%d",&m,&x[i]);//注意输入的格式,标记状态
            for(j=0;j<m;++j)
            {
            	scanf("%d%d",&a,&b);
            	map[i][a]=b;
			}
        }
        floyd();
        int minn=inf;
        for(i=0;i<n;++i)
        {
        	if(x[i])//临海的城市才更新最值
        	{
        		minn=min(minn,map[0][i]);
			}
		}
		printf("%d\n",minn);//找到输出.
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值