1205 Constructing Roads In JGShining's Kingdom【lis】

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19615 Accepted Submission(s): 5545


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.

Sample Input
  
  
2 1 2 2 1 3 1 2 2 3 3 1

Sample Output
  
  
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.


转化一下模型,就成了lis 的模板题.....直接用二分更新最长单调子序列,求出长度,最坑的是,输出,一条路的时候 road 是单数,否则是 复数.....

另外就是空行的控制,没有说空行怎么控制,然而却是每一行末尾都有空行...........

.也是醉了,睡觉!


喜欢手动构造二分函数.....推荐stl..

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
struct match
{
	int l,r;//其实可以只使用一个数组
}x[500005];
int n,t=0,y[500005];
int cmp(match a,match b)//排好一半的顺序
{
	return a.r<b.r;
}
int search(int l,int r,int s)//二分查找
{
	while(l<r)
	{
		int mid=(l+r)>>1;
		if(y[mid]<s)
		{
			l=mid+1;
		}
		else
		{
			r=mid;
		}
	}
	return l;
}
void slove()
{
	sort(x,x+n,cmp);
	int len=1;
	y[0]=x[0].l;
	for(int i=1;i<n;++i)
	{
		int temp=search(0,len,x[i].l);
		if(temp==len)//判断是否更新
		{
			++len;
		}
		y[temp]=x[i].l;//替换
	}
	printf("Case %d:\n",++t);
	if(len>1)
	{
		printf("My king, at most %d roads can be built.\n\n",len);//坑死人的格式!!
		return;
	}
	printf("My king, at most %d road can be built.\n\n",len);
}
int main()
{
	//freopen("shuju.txt","r",stdin);
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
		{
			scanf("%d%d",&x[i].l,&x[i].r);
		}
		slove();
	}
	return 0;
}

如果用特殊值来标记数组,可以直接无脑二分更新长度,个人不喜欢...........

这样虽然写的犊砸,但是利于想思路......



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值