hdu 1013 Digital Roots【数根计算 余九解法】

33 篇文章 0 订阅

Digital Roots

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63164 Accepted Submission(s): 19608


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.

Sample Input
  
  
24 39 0

Sample Output
  
  
6 3

如果直接暴力循环,ac 还是没问题的,不过这道题有个更简单的解法:余九法


很久之前接触到的余九法求数根了,权当是温习一下:

1,把这个数每一位的数字都加起来,得到一个数

2,如果得到的这个数不是一个一位数,就重复 1 操作,否则操作 3

3,得到的这个是就是原先给出的数的数根


然后用余九法求数根的话,如果这个数是0 结果就是 0 (!!!一定注意这个特判!!!),否则直接把这个数的每个位上的数字都加起来,对 9 取余,如果结果为 0 ,那么结果是 9,否则就是求得的数值!

或者

把每一位数字的和加起来 减去 1,对 9 取余之后 ,再加 1,得到的也是正确答案!


这个解法的原理也许个人理解的不够透彻,有兴趣的可以自己搜索弃九法以及同余的相关定理....

数论好难理解,瞬间感觉智商不够了.........


#include<stdio.h>
int main()
{
	char x[1005];
	while(scanf("%s",&x),x[0]!='0')
	{
		int tp=0;
		for(int i=0;x[i];++i)
		{
			tp+=x[i]-'0';
		}
		tp%=9;
		if(!tp)
		{
			tp=9;
			/*if(x[0]=='0')//这里是特判 0 的情况,本题不需要
			{
				tp=0;
			}*/
		}
		printf("%d\n",tp);
	}
	return 0;
}


温故而知新!


#include<stdio.h>
int main()
{
	char x[1005];
	while(scanf("%s",&x))
	{
		int tp=0;
		for(int i=0;x[i];++i)
		{
			tp+=x[i]-'0';
		}
		tp=(tp-1)%9+1;
		printf("%d\n",tp);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值