Poj 2431 Expedition【stl】

14 篇文章 0 订阅

Expedition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10490 Accepted: 3064

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.


给出一条路上的所有的加油站距离终点的距离和加油站的总油量,整条路的总长度和汽车在起点的油量,汽车的油桶无限大,问汽车能否到达终点,如果可以,输出最少加油的次数,否则输出 -1.

优先队列,每次加油时,都选择油量未用完时经过的油量最多的那个加油站去加油,这样能确保全局最优,注意加油站排序。


#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int n,l,p;
struct way
{
	int l,p;
	bool friend operator <(way a,way b)
	{
		return a.p<b.p;
	}
}x[10005];
bool cmp(way a,way b)
{
	return a.l<b.l;
}
int slove()
{
	int ans=0,len=0,tank=p;
	priority_queue<way> q;
	for(int i=0;i<=n;++i)
	{
		int dis=x[i].l-len;//下一个加油站的距离 
		while(tank<dis)//油用完了 
		{
			if(q.empty())//如果无法加油 
			{
				return -1;
			}
			way tp=q.top();q.pop();//取出最大的进行加油 
			tank+=tp.p;
			++ans;
		}
		tank-=dis;
		len=x[i].l;
		q.push(x[i]);
	}
	return ans;
}
int main()
{
	//freopen("shuju.txt","r",stdin);
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
		{
			scanf("%d%d",&x[i].l,&x[i].p);
		}
		scanf("%d%d",&l,&p);
		x[n].l=0;x[n].p=0;
		for(int i=0;i<=n;++i)
		{
			x[i].l=l-x[i].l;
		}
		sort(x,x+n+1,cmp);
		printf("%d\n",slove()); 
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值