Hdu 5611 Baby Ming and phone number【日期计算等等】

Baby Ming and phone number

Time Limit: 3000/1500 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1656 Accepted Submission(s): 434


Problem Description
Baby Ming collected lots of cell phone numbers, and he wants to sell them for money.

He thinks normal number can be sold for b yuan, while number with following features can be sold for a yuan.

1.The last five numbers are the same. (such as 123-4567-7777)

2.The last five numbers are successive increasing or decreasing, and the diffidence between two adjacent digits is 1 . (such as 188-0002-3456)

3.The last eight numbers are a date number, the date of which is between Jar 1st, 1980 and Dec 31th, 2016. (such as 188-1888-0809,means August ninth,1888)

Baby Ming wants to know how much he can earn if he sells all the numbers.

Input
In the first line contains a single positive integer T , indicating number of test case.

In the second line there is a positive integer n , which means how many numbers Baby Ming has.(no two same phone number)

In the third line there are 2 positive integers a,b , which means two kinds of phone number can sell a yuan and b yuan.

In the next n lines there are n cell phone numbers.(|phone number|==11, the first number can’t be 0)

1T30,b<1000,0<a,n100,000

Output
How much Baby Nero can earn.

Sample Input
  
  
1 5 100000 1000 12319990212 11111111111 22222223456 10022221111 32165491212

Sample Output
  
  
302000

题意:

给出一定的条件,满足条件的可以卖a元,否则b元,问这个人能赚多少钱。


题解:

需要完全模拟题目的条件,另外日期计算的时候注意细节的考虑,比如闰年等


#include<stdio.h>
typedef long long ll;
int x[]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int abs(int x)
{
    return x<0?-x:x;
}
int fun(int x)
{
    return x%4==0&&x%100!=0||x%400==0;
}
bool one(char s[])
{
    for(int i=7;i<11;++i)
    {
        if(s[i]!=s[i-1])
        {
            return 0;
        }
    }
    return 1;
}
bool two(char s[])
{
    for(int i=7;i<10;++i)
    {
        if(s[i]-s[i-1]!=s[i+1]-s[i]||abs(s[i]-s[i-1])!=1)
        {
            return 0;
        }
    }
    return 1;
}
bool three(char s[])
{
    int year=0,month=0,day=0;
    for(int i=3;i<11;++i)
    {
        if(i<7)
        {
            year=year*10+(s[i]-'0');
        }
        else if(i<9)
        {
            month=month*10+(s[i]-'0');
        }
        else
        {
            day=day*10+(s[i]-'0');
        }
    }
    if(year<1980||year>2016||month==0||month>12||day==0||day>31)
        //不符合日期的规则
    {
        return 0;
    }
    if(month==2)//讨论二月
    {
        int tp=fun(year);//判断闰年
        return day<=x[month]+tp;
    }
    else//其他月份
    {
        return day<=x[month];
    }
}
bool judge(char s[])
{
    return one(s)||two(s)||three(s);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll n,a,b;
        scanf("%I64d%I64d%I64d",&n,&a,&b);
        ll ans=0;char s[15];
        while(n--)
        {
            scanf("%s",s);
            ans+=judge(s)?a:b;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值