Poj 3050 Hopscotch【dfs】

36 篇文章 0 订阅

Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2946 Accepted: 2067

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

题意:

给出5*5的地图,每个位置都有不同的数,可以从任何一个位置出发,上下左右走动五部,初始位置的数字和经过的数字组合成一个数字,问组合成的数字一共有所少种可能...


题解:

并没有什么规律可找,只能进行暴力搜索,对每个位置都进行暴力搜索,同时用set 来标记和统计不同元素的个数


#include<stdio.h>
#include<string.h>
#include<set> 
using namespace std;
int n=5,map[105][105],dx[]={0,0,-1,1},dy[]={-1,1,0,0};
set<int> vis;
void dfs(int x,int y,int cnt,int num)
{
	if(cnt==5)
	{
		vis.insert(num);
		return;
	}
	for(int i=0;i<4;++i)
	{
		int tx=x+dx[i],ty=y+dy[i];
		if(tx<0||tx>=n||ty<0||ty>=n)
		{
			continue;
		}
		dfs(tx,ty,cnt+1,10*num+map[tx][ty]);
	}
}
int main()
{
	vis.clear();
	while(~scanf("%d",&map[0][0]))
	{
		for(int i=1;i<5;++i)
		{
			scanf("%d",&map[0][i]);
		}
		for(int i=1;i<5;++i)
		{
			for(int j=0;j<5;++j)
			{
				scanf("%d",&map[i][j]);
			}
		}
		for(int i=0;i<n;++i)
		{
			for(int j=0;j<n;++j)
			{
				dfs(i,j,0,map[i][j]);
			}
		}
		/*for(set<int>::iterator i=vis.begin();i!=vis.end();++i)
		{
			printf("%d\n",*i);
		}*/
		printf("%d\n",vis.size());
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值