Stripies
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 14292 | Accepted: 6707 |
Description
Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.
You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together.
Input
The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.
Output
The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.
Sample Input
3 72 30 50
Sample Output
120.000
题意:
给出n 个物体,分别给出每个的质量,并且两个物体(假设质量分别为m1,m2)相撞的时候变成一个物体,质量为2*sqrt(m1*m2),并且只会出现两个两个物品碰撞的情况,问最终能得到的物体的最小质量是多少。
题解:
贪心策略如下:
类似于哈弗曼树的方法,每次选举两个当前最大的数值进行运算,直到剩下一个物品。
使用优先队列处理比较方便。
贪心证明如下:
假设三个物体,质量分别为 a,b,c,(a>=b>=c)可以证明:
2*sqrt(2*c*sqrt(a*b)) <=2*sqrt(2*a*sqrt(b*c))
证明三个元素每次选举两个最大质量是最优的选取方法,类推到n,依然成立,证毕。
/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cstring>
#include<queue>
#include<cmath>
#include<algorithm>
using namespace std;
int main()
{
int n;
while(~scanf("%d",&n))
{
priority_queue<double> q;
for(int i=0;i<n;++i)
{
double tp;
scanf("%lf",&tp);
q.push(tp);
}
while(q.size()>1)
{
double a=q.top();q.pop();
double b=q.top();q.pop();
double tp=2*sqrt(a*b);
q.push(tp);
}
printf("%.3f\n",q.top());
}
return 0;
}