Ananagrams Uva 156

20 篇文章 0 订阅

Ananagrams (map的使用)

Most crossword puzzle fans are used to anagrams–groups of words with the same letters in different orders–for example OPTS, SPOT, STOP, POTS and POST. Some words however do not have this attribute, no matter how you rearrange their letters, you cannot form another word. Such words are called ananagrams, an example is QUIZ.

Obviously such definitions depend on the domain within which we are working; you might think that ATHENE is an ananagram, whereas any chemist would quickly produce ETHANE. One possible domain would be the entire English language, but this could lead to some problems. One could restrict the domain to, say, Music, in which case SCALE becomes a relative ananagram (LACES is not in the same domain) but NOTE is not since it can produce TONE.

Write a program that will read in the dictionary of a restricted domain and determine the relative ananagrams. Note that single letter words are, ipso facto, relative ananagrams since they cannot be “rearranged” at all. The dictionary will contain no more than 1000 words.

输入一些单词,找出所有满足如下条件的单词:该单词不能通过字母重排,得到输入文
本中的另外一个单词。在判断是否满足条件时,字母不分大小写,但在输出时应保留输入中的大小写,按字典序进行排列(所有大写字母在所有小写字母的前面)。

Input

Input will consist of a series of lines. No line will be more than 80 characters long, but may contain any number of words. Words consist of up to 20 upper and/or lower case letters, and will not be broken across lines. Spaces may appear freely around words, and at least one space separates multiple words on the same line. Note that words that contain the same letters but of differing case are considered to be anagrams of each other, thus tIeD and EdiT are anagrams. The file will be terminated by a line consisting of a single #.

Output

Output will consist of a series of lines. Each line will consist of a single word that is a relative ananagram in the input dictionary. Words must be output in lexicographic (case-sensitive) order. There will always be at least one relative ananagram.

样例输入:

ladder came tape soon leader acme RIDE lone Dreis peat
ScAlE orb eye Rides dealer NotE derail LaCeS drIednoel dire Disk mace Rob dries
#

样例输出:

Disk
NotE
derail
drIed
eye
ladder
soon

分析:

用一个vector存储出现过的单词,把所有单词统一成一个形式,即先把所有字母改为小写,将该单词排序,再放到map里统计可排列成相同单词的数目,把出现次数为1的单词输出。

code

#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#include <vector>
#include <map>
using namespace std;

/* 将单词标准化 */
string standard( string str ) {
    for( int i = 0; i < str.size(); i++ ) {
        str[i] = tolower( str[i] );
    }
    sort( str.begin(), str.end() );  //把单词中的字母按字典序排列
    return str;
}

int main() {
    //freopen("input.txt", "r", stdin);
    vector<string> words;  //存储所有单词
    map<string, int> _map;  //记录标准化后的单词出现次数
    string str;

    while( cin >> str && str != "#" ) {
        words.push_back( str );
        if ( ! _map.count( standard(str) ) ) {  //单词未出现,将其数目标记为0
            _map[ standard(str) ] = 0;  //可看作初始化,尽管该单词已经出现,但此时标记为0即可,因为后续还会自加
        }
        _map[ standard(str) ]++;  //因为该单词出现了,所以次数加1(若首次出现,刚好0加1后变为1;若不是首次出现,次数加1)
    }

    vector<string> ans;
    vector<string>::iterator it;
    for( it = words.begin(); it != words.end(); it++ ) {
        if ( _map[ standard(*it) ] == 1 ) {
            ans.push_back( *it );  //将出现次数为1的单词放到ans中
        }
    }

    sort( ans.begin(), ans.end() );  //按字典序排序

    for( it = ans.begin(); it != ans.end(); it++ ) {
        cout << *it << endl;  //输出
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值