问题九十七:Reverse Number

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows:
1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21;
2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21;
3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100. 

Input

Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.

Output

For each test case, you should output its reverse number, one case per line.

Sample Input


3
12
-12
1200

Sample Output


21
-21
2100
#include <stdio.h>

int main()
{
	int i;
	int j;
	int n;
	int tab;                        //标记末尾是否有零
	int num;
	int flag;                      //标记是否是正负数  
	int count;
	int array[100];                 //存储各位的数值

	scanf("%d", &n);
	while(n--)
	{  
		scanf("%d", &num);
        
		j=0;
		tab=1;                //假设末尾有零
	    flag=1;               // 正数为1
		count=0;
		if(num<0 )
		{
            flag=0;            //负数
			num=-1* num;         
		}

		while(num)
		{
			if(num%10==0 && tab!=0)    
			{
			   count++;        //计算零的个数
			}
			else
			{
			   array[j++]=num%10;
			   tab=0;     
			}
			num/=10;
		}

		if(flag==0)     
		{
		    printf("-");
		}

		for(i=0; i<j; i++)
		{
		     printf("%d", array[i]);
		}
        
		for(i=0; i<count; i++)         //打印末尾零的个数
		{
		    printf("0");
		}
		if(n>0)      
		{
		    printf("\n");
		}
	}

	return 0;
}



    



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值