poj2785----折半枚举

4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 23137 Accepted: 6994
Case Time Limit: 5000MS
Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .
Output

For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45
Sample Output

5
Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
Source

Southwestern Europe 2005
题目大意:从4个数列中各选取一个数,使它们的和为0,计算一共有共有多少种取法。
解题思路:如果使用全部枚举的方法,要使用4层循环,所以这里使用折半枚举,从4个数列中选取2个数列进行枚举(比如A和B),然后计算另外两个数列加和的所有情况(比如C和D),然后进行排序,枚举两个数列的加和(A+B),再从另外两个数列的已经经过排序的加和结果(C+D)中查看是否由满足条件的组合结果。
ac代码:

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
const int MAX_N = 4000+10;
int A[MAX_N];
int B[MAX_N];
int C[MAX_N];
int D[MAX_N];
int n;
/*
 * 算法思想:枚举四个数列中的值时间耗费过大,可以折半枚举,
 * 从A和B中进行美剧,将C+D的所有结果排序并且存储,然后进行二分查找
 */
int main() {
    cin>>n;
    int index_of_A = 0;
    int index_of_B = 0;
    int index_of_C = 0;
    int index_of_D = 0;
    for(int i = 0;i < 4 * n;i++){
        switch (i % 4){
            case 0:
                cin>>A[index_of_A++];
                break;
            case 1:
                cin>>B[index_of_B++];
                break;
            case 2:
                cin>>C[index_of_C++];
                break;
            case 3:
                cin>>D[index_of_D++];
                break;
        }
    }
    vector<int> sum;
    //计算C+D的结果
    for(int i = 0;i < n;i++){
        for(int j = 0;j < n;j++){
            sum.push_back(C[i] + D[j]);
        }
    }
    long long res = 0;
    //对加和结果进行排序
    sort(sum.begin(),sum.end());
    for(int i = 0;i < n;i++){
        for(int j = 0;j < n;j++){
            int target_val = -(A[i] + B[j]);
            res += (upper_bound(sum.begin(),sum.end(),target_val) - lower_bound(sum.begin(),sum.end(),target_val));
        }
    }
    cout<<res<<endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值