uva 1587 box

Ivan works at a factory that produces heavy machinery. He has a simple job — he knocks up wooden boxes of different sizes to pack machinery for delivery to the customers. Each box is a rectangular parallelepiped. Ivan uses six rectangular wooden pallets to make a box. Each pallet is used for one side of the box.
Joe delivers pallets for Ivan. Joe is not very smart and often makes mistakes — he brings Ivan pallets that do not fit together to make a box. But Joe does not trust Ivan. It always takes a lot of time to explain Joe that he has made a mistake. Fortunately, Joe adores everything related to computers and sincerely believes that computers never make mistakes. Ivan has decided to use this for his own advantage. Ivan asks you to write a program that given sizes of six rectangular pallets tells whether it is possible to make a box out of them.
Input
Input file contains several test cases. Each of them consists of six lines. Each line describes one pallet and contains two integer numbers w and h (1 ≤ w,h ≤ 10000) — width and height of the pallet in millimeters respectively.
Output
For each test case, print one output line. Write a single word ‘POSSIBLE’ to the output file if it is possible to make a box using six given pallets for its sides. Write a single word ‘IMPOSSIBLE’ if it is not possible to do so.
Sample Input
1345 2584 2584 683 2584 1345 683 1345 683 1345 2584 683 1234 4567 1234 4567 4567 4321 4322 4567 4321 1234 4321 1234
Sample Output
POSSIBLE IMPOSSIBLE
这道题得要注意是长方体 要3条相邻的边不一样 才是正确的   这里首先就行排序 让后再比较 

<span style="font-size:24px;">下面是源码  </span>
<span style="font-size:24px;">#include<stdio.h>
int main()
{
 int temp,i=0,j,a[6],b[6],flag;
 while(scanf("%d%d",&a[0],&b[0])!=EOF)
 {
  if(a[0]<b[0]){temp=a[0];a[0]=b[0];b[0]=temp;}
  for(i=1;i<6;i++)
  {
   scanf("%d%d",&a[i],&b[i]);
   if(a[i]<b[i]){temp=a[i];a[i]=b[i];b[i]=temp;}
  }
  flag=0;
  for(i=0;i<5;i++)
   for(j=i+1;j<6;j++)
   {
    if((a[i]<a[j]) || (a[i]==a[j] && b[i]<b[j]))
    {
     temp=a[i];a[i]=a[j];a[j]=temp;
     temp=b[i];b[i]=b[j];b[j]=temp;
    }
   }
  for(i=0;i<6;i+=2)
   if(a[i]!=a[i+1]||b[i]!=b[i+1])flag=1;
        if(a[0]!=a[2]||b[0]!=a[4]||b[2]!=b[4])flag=1;
     if(flag)printf("IMPOSSIBLE\n");
  else printf("POSSIBLE\n");
 }
 return 0;
}</span>
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值