[HDU1159]-Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
题目描述:给你来两个字符串让你求得两个字符串中的相同最长子序列的长度。
解题思路:由于数据较大,暴力会超时,那么就像dp方向想,通过观察他们的最长公共子序列是一一对应的,拿第一个列子来说:
abcfbc abfcab,dp[i][j]代表str1中前i个字符与str2中前j个字符最多有几个相同的字符,那么现在推理dp[i+1][j+1]
怎么得到,下面就是本题的关键:
如果str1[i+1]==str2[j+1],那么肯定可以得到dp[i+1][j+1]=dp[i][j]+1
但如果str[i]!=str2[j+1],那么dp[i+1][j+1]必然是dp[i][j+1]与dp[i+1][j]中的最大值,这个应该可以不用解释了
最终,我们得到状态转移方程
code如下:
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn = 1001;
int dp[maxn][maxn];
int main()
{
	string strx,stry;
	ios::sync_with_stdio(false);
	while(cin>>strx>>stry)
	{
		int ans=0;
		int lenx = strx.length();
		int leny = stry.length();
		memset(dp,0,sizeof(dp));
		for(int x = 1;x <= lenx;++ x)
			for(int y = 1;y <= leny;++ y)
			{
				if(strx[x-1]==stry[y-1])
					dp[x][y] = dp[x-1][y-1]+1;
				else
					dp[x][y] = max(dp[x-1][y],dp[x][y-1]);
			}
		cout << dp[lenx][leny] << endl;
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值