hdu 5265 技巧题 O(nlogn)求n个数中两数相加取模的最大值

pog loves szh II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2106    Accepted Submission(s): 606


Problem Description
Pog and Szh are playing games.There is a sequence with n numbers, Pog will choose a number A from the sequence. Szh will choose an another number named B from the rest in the sequence. Then the score will be (A+B) mod p .They hope to get the largest score.And what is the largest score?
 

Input
Several groups of data (no more than 5 groups, n1000 ).

For each case:

The following line contains two integers, n(2n100000) p(1p2311)

The following line contains n integers ai(0ai2311)
 

Output
For each case,output an integer means the largest score.
 

Sample Input
  
  
4 4 1 2 3 0 4 4 0 0 2 2
 

Sample Output
  
  
3 2
 

Source

有n个数,从这n个数中选出两个数,不能相同,使得两个数相加取模后的值最大。

可以先进行排序,然后用线性的方法找最大。

排序之前先对所有的数取一遍模,由于模运算的性质,这并不会影响结果。(a+b)%mod==( a%mod+b%mod )%mod。

可以先取排序之后的最后两个数,如果他们的和小于模p,直接输出他们的和,因为这一定是最大的。

否则的话还得找,设置 l 从0开始往后,r从n-1开始往前,对于每个 l ,找到最右边的r,使得a[ l ]+a[ r ]<p,

这时r就不用往前了,因为往前的话值一定会变小,每次找到之后,更新最大值,同时 l 往前一位,但是 r 不用动,

因为数组是有序的,(仔细想想就知道了),这样时间复杂度就控制在线性阶了。

另外2^31-1是2147483647,有符号整型能表示的最大值.


#include<map>
#include<vector>
#include<cstdio>
#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<stack>
#include<queue>
#include<set>
#define inf 0x3f3f3f3f
#define mem(a,x) memset(a,x,sizeof(a))

using namespace std;

typedef long long ll;
typedef pair<int,int> pii;

inline ll in()
{
    ll res=0;char c;
    while((c=getchar())<'0' || c>'9');
    while(c>='0' && c<='9')res=res*10+c-'0',c=getchar();
    return res;
}
ll a[100010];
int main()
{
    int n,p;
    while(~scanf("%d%d",&n,&p))
    {
        for(int i=0;i<n;i++)
        {
            a[i]=in()%p;
        }
        sort(a,a+n);         //排序
        ll mx=(a[n-1]+a[n-2])%p;
        int l=0,r=n-1;
        while(l<r)
        {
            while(r>=0 && a[l]+a[r]>=p)r--;  //防止r<0
            if(l<r) mx=max(mx,a[l]+a[r]);    //r不能小于等于l
            l++;
        }
        cout<<mx<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值