Joseph

Joseph

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2915 Accepted Submission(s): 1637
 
Problem Description
The Joseph\\\\\\\'s problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
 
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
 
Output

            The output file will consist of separate lines containing m corresponding to k in the input file.
 
Sample Input
3
4
0
 
Sample Output
5
30
 
#include <iostream>
#include <cstdio>


using namespace std;
const int maxn = 15;
int ans[maxn];
int joseph[maxn];

int main(){
	int k;
	while(scanf("%d",&k)!=EOF,k){
		if(joseph[k] != 0){//如果之前已经遇到过相同的k值
			printf("%d\n",joseph[k]);//则直接输出。否则会TLE
			continue;
		}

		int m = 1;//最小间隔是1
		int n = 2*k;//计算总人数

		int i;
		for(i = 1 ; i <= k ; ++i){//判断一个m值在k轮里面是否会杀掉好人
			ans[i] = (ans[i-1]+m-1)%(n-i+1);//计算下一个要杀掉的位置.(ans[i-1]+m-1)是下一个要杀掉的索引.(n-i+1):当前剩余人数
			if(ans[i] < k){//如果杀掉了好人
				i=0;//说明当前m值不合适,从心开始试验
				m++;//去下一个m值
			}
		}
		joseph[k] = m;//额k如果已经求出m值了就记录下来。下一次如果是相同的k就不需要再次计算了

		printf("%d\n",m);
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值