02:找第一个只出现一次的字符

02:找第一个只出现一次的字符


总时间限制: 
1000ms 
内存限制: 
65536kB
描述

给定一个只包含小写字母的字符串,请你找到第一个仅出现一次的字符。如果没有,输出no。

输入
一个字符串,长度小于100000。
输出
输出第一个仅出现一次的字符,若没有则输出no。
样例输入
abcabd
样例输出
c
 
 
#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>
#include <iomanip>
#include <string>
#include <cstdio>
#include <string.h>
#include <set>
#include <cmath>
#include <map>
#include <stack>
#include <stdlib.h>
#define MAX_LEN 200
using namespace std;
int a[26] = {0};
int main()
{

    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    string str;
    cin >> str;

    int flag = 0;
    for(int i = 0; i < str.size(); i++){
        string temp1 = str.substr(0,i);
        string temp2 = str.substr(i + 1);
        if(temp1.find(str[i]) == string::npos && temp2.find(str[i]) == string::npos){
            cout << str[i];
            flag = 1;
            break;
        }
    }
    if(!flag){
        cout << "no" << endl;
    }


    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值