acm 4 1001

1.1001

2.

Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. <br><br>We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.<br>

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.<br><br>Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.<br>

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. <br>

Sample Input
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2

Sample Output
  
  
179

3.有 N 的村庄,从 1 到 N 编号,和你应该有些修路,这样每两个村庄可以连接到彼此。我们说两个村庄 A 和 B 连接,当且仅当有一条路之间 A 和 B,或存在一个村庄 C 等,还有一条路之间连接 A 和 C,和 C 和 B。我们知道一些村庄之间已经有一些道路和你的工作是的生成一些道路这样的所有村庄都是连接和建的所有道路长度最小。输入第一行是一个整数 N (3 < = N < = 100),这是村庄的数字。然后来 N 行,其中第 i 个包含 N 的整数,而且这些 N 整数 j th 距离 (该距离应内的整数 [1,1000年]) 之间村庄 i 和村庄 j。然后还有一个整数 Q (0 < = Q < = N * (N + 1) / 2)。然后来的 Q 行,每行包含两个整数和 b (1 < = < b < = N),这意味着村庄之间的公路和村庄 b 建成。输出你应该输出行包含一个整数,是打造的所有村庄都被连接的所有道路的长度,此值是最低。
4.图算法

5.

#include <iostream>
#include <queue>
#include<stdio.h>
using namespace std;
const long MAXN=10000;
long father[MAXN];
long m,n;//点数 边数
//m标号从1开始
typedef struct
{
    long from;
    long to;
    long cost;
}Edge;


bool operator <(const Edge &a, const Edge &b)
{
    return a.cost>b.cost;
}
priority_queue<Edge> q;
Edge e[100005];
void MakeSet()
{
    long i;
    for (i=0;i<=m;++i)
    {
        father[i]=i;
    }
}
long Find(long i)
{
    long r=i;
    while (father[r]!=r)
    {
        r=father[r];
    }
    while (father[i]!=r)
    {
        long j=father[i];
        father[i]=r;
        i=j;
    }
    return r;
}
void Unition(long x,long y)
{
    long fx=Find(x);
    long fy=Find(y);
    if (fx!=fy)
    {
        father[fx]=fy;
    }
}
void Init()
{
    while (!q.empty())
    {
        q.pop();
    }
    MakeSet();
    long i,j;
    long cc;
    int pp=0;
    for(i=1;i<=m;++i)
    {
        for(j=1;j<=m;j++)
        {
            scanf("%ld",&cc);
            e[pp].from=i;
            e[pp].to=j;
            e[pp].cost=cc;
            pp++;
        }
    }
    long qqq,aaa,bbb;
    scanf("%ld",&qqq);
    for(i=0;i<qqq;i++)
    {
        scanf("%ld%ld",&aaa,&bbb);
        for(j=0;j<pp;j++)
        {
            if(e[j].from==aaa)
            {
                if(e[j].to==bbb)
                {
                    e[j].cost=0;
                }
            }
            if(e[j].from==bbb)
            {
                if(e[j].to==aaa)
                {
                    e[j].cost=0;
                }
            }
        }
    }
    for(i=0;i<pp;i++)
    {
        q.push(e[i]);
    }
}
void print(long cost)
{
    printf("%ld\n",cost);
}
void Kruskal()
{
    Init();
    long t=0;//表示合并次数
    long cost=0;
    Edge e;
    while (!q.empty()&&t<m-1)
    {
        e=q.top();
        long v1=e.from;
        long v2=e.to;
        if (Find(v1)!=Find(v2))
        {
            Unition(v1,v2);
            cost+=e.cost;
            ++t;
        }
        q.pop();
    }
    print(cost);
}


int main()
{
    while(~scanf("%ld",&m))//输入点与边
    {
        Kruskal();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值