呵呵,刚刚水了一道题目。简单题就要水!PKU2895,精简到70行代码!

最近大家都喜欢水题,我觉得简单题才应该水,不用怎么想特殊的算法。基本上可以说是送分题。这个程序我重写了一遍,可以说是水出来的,三十分钟完成,一遍AC!没有什么特别的算法。

我的程序代码: 

 

///*
//Problem B:Best SMS to Type
//Time Limit:1000MS  Memory Limit:65536K
//Total Submit:446 Accepted:188
//
//Description
//Using SMS today is more than a pleasing hobby. As the number of messages one sends through this service grows, the need to type them fast is better felt. Sometimes, one wonders how fast a message can be typed. Changing some words to their synonyms, might help type the whole message faster, if we were able to quickly calculate the time needed for a specific message.
//
//In the following, we assume that each message is a string of capital English letters and space character. The letters 'A' through 'Z' are assigned to keys '2' to '9', as in the following figure. To type a letter, one should press its key 1, 2, 3, or 4 times, depending on the position of the letter from left to right.
//
//If two consecutive letters of the message are mapped to one key, one should wait for the first letter to be fixed on the screen and then use the key again to type the second one. For instance, to type the letter 'X', one should press '9' twice. If the next letter of the message is not on the same key, one can continue to type the rest of the message. Otherwise, one has to wait for some time, so that the typed 'X' is fixed, and then the next letter ('W', 'X', 'Y', or 'Z') can be typed. To type whitespace, we use the key '1'.As there is no letter mapped to the key '1', the whitespace needs no time to be fixed.
//
//You are given the time needed to press any key, and the time one should wait for a letter to be fixed. Your program should find the minimum time needed to type a nonempty string, given the above rules.
//
//Input
//The input file contains multiple test cases. The first line of the input, contains t, the number of test cases that follow. Each of the following t blocks, describes a test case.
//
//The first line of each block contains p and w (1 <= p,w <= 1000), which show the amount of time in milliseconds for pressing a letter and waiting for it to be fixed, respectively. The second line contains a non-empty string of length at most 1000, consisting of spaces or capital English letters. There is no leading or trailing spaces in a line.
//
//
//Output
//For each test case, output one line showing the time needed to type the message in milliseconds.
//
//
//Sample Input
//
//
//1
//2 10
//ABBAS SALAM
//
//
//Sample Output
//
//
//72
//*/

#include "iostream"
#include "string"

bool pandun(char ch1,char ch2)
{
 if((ch1=='A'||ch1=='B'||ch1=='C')&&(ch2=='A'||ch2=='B'||ch2=='C'))
  return true;
 else if((ch1=='D'||ch1=='E'||ch1=='F')&&(ch2=='D'||ch2=='E'||ch2=='F'))
  return true;
 else if((ch1=='G'||ch1=='H'||ch1=='I')&&(ch2=='G'||ch2=='H'||ch2=='I'))
  return true;
 else if((ch1=='J'||ch1=='K'||ch1=='L')&&(ch2=='J'||ch2=='K'||ch2=='L'))
  return true;
 else if((ch1=='M'||ch1=='N'||ch1=='O')&&(ch2=='M'||ch2=='N'||ch2=='O'))
  return true;
 else if((ch1=='P'||ch1=='Q'||ch1=='R'||ch1=='S')&&(ch2=='P'||ch2=='Q'||ch2=='R'||ch2=='S'))
  return true;
 else if((ch1=='T'||ch1=='U'||ch1=='V')&&(ch2=='T'||ch2=='U'||ch2=='V'))
  return true;
 else if((ch1=='W'||ch1=='X'||ch1=='Y'||ch1=='Z')&&(ch2=='W'||ch2=='X'||ch2=='Y'||ch2=='Z'))
  return true;
 else
  return false;

}
int number(char ch1)
{
 if((ch1=='A'||ch1=='B'||ch1=='C'))
  return (ch1-'A')%3;
 else if((ch1=='D'||ch1=='E'||ch1=='F'))
  return (ch1-'D')%3;
 else if((ch1=='G'||ch1=='H'||ch1=='I'))
  return (ch1-'G')%3;
 else if((ch1=='J'||ch1=='K'||ch1=='L'))
  return (ch1-'J')%3;
 else if((ch1=='M'||ch1=='N'||ch1=='O'))
  return (ch1-'M')%3;
 else if((ch1=='P'||ch1=='Q'||ch1=='R'||ch1=='S'))
  return (ch1-'P')%4;
 else if((ch1=='T'||ch1=='U'||ch1=='V'))
  return (ch1-'T')%3;
 else if((ch1=='W'||ch1=='X'||ch1=='Y'||ch1=='Z'))
  return (ch1-'W')%4;
 else
  return 0;
}
using namespace std;

int main()
{
 int n,p,w,len,time=0,i;
 char ch[1000];
 cin>>n;
 while(n)
 {
  cin>>p>>w;
  ch[0]=getchar();
  gets(ch);
  len=strlen(ch);
  for(i=0;i+1<len;i++)
  {
   time+=(p*(1+number(ch[i])));
   if(pandun(ch[i],ch[i+1]))
    time+=w;
  }
  time+=(p*(1+number(ch[i])));
  cout<<time<<endl;
  time=0;
  n--;
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值