《算法艺术与信息学竞赛》之 贪心 例一 Gone Fishing

Description

John is going on a fishing trip. He has h hours available (1 <= h <= 16), and there are n lakes in the area (2 <= n <= 25) all reachable along a single, one-way road. John starts at lake 1, but he can finish at any lake he wants. He can only travel from one lake to the next one, but he does not have to stop at any lake unless he wishes to. For each i = 1,…,n - 1, the number of 5-minute intervals it takes to travel from lake i to lake i + 1 is denoted ti (0 < ti <=192). For example, t3 = 4 means that it takes 20 minutes to travel from lake 3 to lake 4. To help plan his fishing trip, John has gathered some information about the lakes. For each lake i, the number of fish expected to be caught in the initial 5 minutes, denoted fi( fi >= 0 ), is known. Each 5 minutes of fishing decreases the number of fish expected to be caught in the next 5-minute interval by a constant rate of di (di >= 0). If the number of fish expected to be caught in an interval is less than or equal to di , there will be no more fish left in the lake in the next interval. To simplify the planning, John assumes that no one else will be fishing at the lakes to affect the number of fish he expects to catch.
Write a program to help John plan his fishing trip to maximize the number of fish expected to be caught. The number of minutes spent at each lake must be a multiple of 5.
Input

You will be given a number of cases in the input. Each case starts with a line containing n. This is followed by a line containing h. Next, there is a line of n integers specifying fi (1 <= i <=n), then a line of n integers di (1 <=i <=n), and finally, a line of n - 1 integers ti (1 <=i <=n - 1). Input is terminated by a case in which n = 0.
Output

For each test case, print the number of minutes spent at each lake, separated by commas, for the plan achieving the maximum number of fish expected to be caught (you should print the entire plan on one line even if it exceeds 80 characters). This is followed by a line containing the number of fish expected.
If multiple plans exist, choose the one that spends as long as possible at lake 1, even if no fish are expected to be caught in some intervals. If there is still a tie, choose the one that spends as long as possible at lake 2, and so on. Insert a blank line between cases.
Sample Input

2
1
10 1
2 5
2
4
4
10 15 20 17
0 3 4 3
1 2 3
4
4
10 15 50 30
0 3 4 3
1 2 3
0
Sample Output

45, 5
Number of fish expected: 31

240, 0, 0, 0
Number of fish expected: 480

115, 10, 50, 35
Number of fish expected: 724
本题是贪心应用的一个经典例子,思路很简单,因为所有的湖在一条直线上,且按标号从小到大,所以要在前k个湖中钓鱼只需要走1~k就可以了。我们首先枚举在前多少个湖里钓鱼,接着将时间减去路上花的时间,就可以认为接下来到每一个湖(前k个中)都可以“瞬移”,所以我们就能很简单的选择钓鱼的位置并取得最优解,用c++STL中的堆(优先队列)在排序上可以获得一个log级别的算法,所以就能很快的得到结果。接下来上代码

#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int n,h,d[30],t[30];
struct node{
    int num,sum;
    friend bool operator <(node a,node b){
        if(a.sum!=b.sum)
            return a.sum<b.sum;
        else
            return a.num>b.num;//鱼一样多按编号排 
    }
}f[30];
int main(){
    while(scanf("%d",&n)&&n){//多组数据 
        scanf("%d",&h);
        h*=60;//时间 
        for(int i=1;i<=26;i++)
            f[i].sum=0;//初值 
        memset(d,0,sizeof(d));
        memset(t,0,sizeof(t));
        for(int i=1;i<=n;i++){
            scanf("%d",&f[i].sum);
            f[i].num=i;//输入,利用结构体存储编号和初始鱼的数量 
        }
        for(int i=1;i<=n;i++)
            scanf("%d",d+i);//d[i]数组 
        for(int i=1;i<n;i++){
            scanf("%d",&t[i]);
            t[i]+=t[i-1];//前缀和做个小优化 
        }
        int ti[n+1],ans=-1;
        memset(ti,0,sizeof(ti));
        for(int i=1;i<=n;i++){//枚举到前几个鱼塘钓鱼 
            priority_queue<node> q;//优先队列 
            int an=0;//当前最优值 
            for(int j=1;j<=i;j++)
                q.push(f[j]);
            int tim[n+1],tt=h;
            tt-=t[i-1]*5;//路上的时间 
            memset(tim,0,sizeof(tim));
            while(tt>0){//开始钓鱼 
                node ff=q.top();
                q.pop();
                tim[ff.num]+=5;
                an+=ff.sum;
                ff.sum-=d[ff.num];
                if(ff.sum<0)
                    ff.sum=0;
                q.push(ff);
                tt-=5;
            }
            if(an>ans){//取最优解 
                for(int j=1;j<=n;j++)
                    ti[j]=tim[j];
                ans=an;
            }
        }
        for(int i=1;i<n;i++)
            printf("%d, ",ti[i]);
        printf("%d\n",ti[n]);
        printf("Number of fish expected: %d\n\n",ans);
    }
    return 0;
}

这个代码修改过多次,请读者朋友们一定要注意看题,我第一遍错在没有加逗号,第二遍没有注意每次换两行,所以还是要细心啊。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值