POJ3625 Building Roads

Building Roads
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10539 Accepted: 2972

Description

Farmer John had just acquired several new farms! He wants to connect the farms with roads so that he can travel from any farm to any other farm via a sequence of roads; roads already connect some of the farms.

Each of the N (1 ≤ N ≤ 1,000) farms (conveniently numbered 1..N) is represented by a position (XiYi) on the plane (0 ≤ X≤ 1,000,000; 0 ≤ Y≤ 1,000,000). Given the preexisting M roads (1 ≤ M ≤ 1,000) as pairs of connected farms, help Farmer John determine the smallest length of additional roads he must build to connect all his farms.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Two space-separated integers: Xand Y
* Lines N+2..N+M+2: Two space-separated integers: i and j, indicating that there is already a road connecting the farm i and farm j.

Output

* Line 1: Smallest length of additional roads required to connect all farms, printed without rounding to two decimal places. Be sure to calculate distances as 64-bit floating point numbers.

Sample Input

4 1
1 1
3 1
2 3
4 3
1 4

Sample Output

4.00

思路:裸的Prim,刚开始卡在了把点之间的距离存在邻接矩阵中,后来发现,想多了~

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define MAXN 1005
using namespace std;

struct Node
{
    double x,y;
};

int n,m;
double sum;
double dis[MAXN][MAXN];
double cost[MAXN];
bool vis[MAXN];

inline double Distance(double xf,double yf,double xs,double ys)
{
    return sqrt((xf-xs)*(xf-xs)+(yf-ys)*(yf-ys));
}

inline void Prim(int start)
{
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        cost[i]=dis[start][i];
    sum=0.0;
    vis[start]=true;
    for(int i=2;i<=n;i++)
    {
        int k;
        double MX=2000000;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j] && cost[j]<MX)
            {
                MX=cost[j];
                k=j;
            }
        }
        sum+=MX;
        vis[k]=true;
        for(int j=1;j<=n;j++)
            if(!vis[j] && cost[j]>dis[k][j]) cost[j]=dis[k][j];
    }
}

inline void init()
{
    for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)
            dis[i][j]=2000000.5;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        init();   //对dis数组进行初始化
        Node node[n+1];
        for(int i=1;i<=n;i++)
            scanf("%lf%lf",&node[i].x,&node[i].y);
        for(int i=1;i<n;i++)
            for(int j=i+1;j<=n;j++)
                dis[i][j]=dis[j][i]=Distance(node[i].x,node[i].y,node[j].x,node[j].y);  //求出距离
        for(int i=0;i<m;i++)
        {
            int tx,ty;
            scanf("%d%d",&tx,&ty);
            dis[tx][ty]=0;dis[ty][tx]=0; //两点已经通了,所以为0
        }
        Prim(1);
        printf("%.2f\n",sum);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值