OJ 1829 Problem B 新奇的加法运算

Description

定义类newInt,包括:

  1. int类型的数据成员。

  2. 重载运算符“+”。计算规则为:将A、B对应位置上的数字相加,只保留个位数作为结果的对应位置上的数字。比如:876 + 543 = 319。注意:该运算不改变两个操作数的值。

  3. 重载输入和输出运算符,用于输入和输出对象的属性值。

  4. 无参构造函数和带参构造函数。

Input

第1行N>0,表示测试用例数量。

每个测试用例包括2个非负整数,用空格隔开。

Output

见样例。

Sample Input

4
876 543
999 9999
9 1999
199 88

Sample Output

876 + 543 = 319
999 + 9999 = 9888
9 + 1999 = 1998
199 + 88 = 177

HINT

不能使用string、char等字符或字符串类型。

Append Code

int main()
{
    int cases;
    newInt a, b, c;
    cin>>cases;
    for (int i = 0; i < cases; i++)
    {
        cin>>a>>b;
        c = a + b;
        cout<<a<<" + "<<b<<" = "<<c<<endl;
    }
    return 0;
}

AC代码

#include <iostream>
using namespace std;

class newInt {
private:
    int num;
public:
    newInt(int t = 0) : num(t) {}
    newInt operator+(newInt a) {
        int f = 0;
        int Max, Min;
        if(num > a.num) {
            Max = num; Min = a.num;
        } else {
            Max = a.num; Min = num;
        }
        int sum = 0;
        while (Max != 0) {
            f++;
            int temp;
            temp = (Max%10 + Min%10) % 10;
            Max /= 10;
            Min /= 10;
            for(int i = 1; i < f; i++) {
                temp *= 10;
            }
            sum += temp;
        }
        newInt newInt1(sum);
        return newInt1;
    }
    friend istream& operator>> (istream &is, newInt &a) {
        cin >> a.num;
        return is;
    }
    friend ostream &operator<<(ostream &os, newInt &a) {
        os << a.num;
        return os;
    }
};
int main()
{
    int cases;
    newInt a, b, c;
    cin>>cases;
    for (int i = 0; i < cases; i++)
    {
        cin>>a>>b;
        c = a + b;
        cout<<a<<" + "<<b<<" = "<<c<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值