UVa-12186 Another Crisis (dp)

20 篇文章 0 订阅
5 篇文章 0 订阅

A couple of years ago, a new world wide crisis started, leaving many people with economical problems.Some workers of a particular company are trying to ask for an increase in their salaries.

The company has a strict hierarchy, in which each employee has exactly one direct boss, with theexception of the owner of the company that has no boss. Employees that are not bosses of any otheremployee are called workers. The rest of the employees and the owner are calledbosses.

To ask for a salary increase, a worker should file a petition to his direct boss. Of course, eachboss is encouraged to try to make their subordinates happy with their current income, making thecompany’s profit as high as possible. However, when at least Tpercent of its direct subordinates havefiled a petition, that boss will be pressured and have no choice but to file a petition himself to his owndirect boss. Each boss files at most 1 petition to his own direct boss, regardless on how many of hissubordinates filed him a petition. A boss only accounts his direct subordinates (the ones that filed hima petition and the ones that didn’t) to calculate the pressure percentage.

Note that a boss can have both workers and bosses as direct subordinates at the same time. Sucha boss may receive petitions from both kinds of employees, and each direct subordinate, regardless ofits kind, will be accounted as 1 when checking the pressure percentage.

When a petition file gets all the way up to the owner of the company, all salaries are increased. Theworkers’ union is desperately trying to make that happen, so they need to convince many workers tofile a petition to their direct boss.

Given the company’s hierarchy and the parameterT, you have to find out the minimum number ofworkers that have to file a petition in order to make the owner receive a petition.

Input

There are several test cases. The input for each test case is given in exactly two lines. The first linecontains two integersN andT (1N105, 1 T 100), separated by a single space.N indicatesthe number of employees of the company (not counting the owner) andT is the parameter describedabove. Each of the employees is identified by an integer between 1 andN. The owner is identified bythe number 0. The second line contains a list of integers separated by single spaces. The integerBi,at positioni on this list (starting from 1), indicates the identification of the direct boss of employeei(0Bii1).

The last test case is followed by a line containing two zeros separated by a single space.

Output

For each test case output a single line containing a single integer with the minimum number of workersthat need to file a petition in order to get the owner of the company to receive a petition.

Sample Input

3 100
0 0 0
3 50
0 0 0
1 4 60 

0 0 1 1 2 2 2 5 7 5 7 5 7 5 

0 0

Sample Output

325 



#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
#define INF 0x3f3f3f3
const int N=100005;
const int mod=1e9+7;

int n,t,b[N];

vector<int> sons[N];

int dp(int u){
    if (sons[u].empty()) return 1;
    int k=sons[u].size();
    vector<int> d;
    for (int i=0; i<k; i++) {
        d.push_back(dp(sons[u][i]));
    }
    sort(d.begin(), d.end());
    int c=(k*t-1)/100+1;
    int ans=0;
    for (int i=0; i<c; i++) {
        ans+=d[i];
    }
    return ans;
}

int main(){
    while (cin>>n>>t&&n) {
        for (int i=0; i<=n; i++) {
            if (!sons[i].empty()) {
                sons[i].clear();
            }
        }
        for (int i=1; i<=n; i++) {
            scanf("%d",&b[i]);
            sons[b[i]].push_back(i);
        }
        cout<<dp(0)<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值