HDU 1301 Jungle Roads(最小生成树Kruskal)

77 篇文章 0 订阅
14 篇文章 0 订阅

Jungle Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6073    Accepted Submission(s): 4402


Problem Description

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 
 

Sample Input
  
  
9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0
 

Sample Output
  
  
216 30

分析:有n个结点,求把n个结点连通的最小边数和

最小生成树问题,第一次写Kruskal算法,在这里介绍一下。

kruskal算法是每次把最小边加入集合,对边进行一个从小到大的排序,然后每次取最小边放入边集合中,并确定每次放入的边都有新结点加入已访问的结点集合。

代码如下:


第一次代码如下:

#include <stdio.h>
#include <algorithm>
#include <string.h>
#define INF 10000000
using namespace std;
struct node{
	int u,v,w;
/*	bool operator<(const node &p)const{  
         return w<p.w;
     }*/
}edge[30];
int pre[30],n,sum;
int map[30][30];

bool cmp(node a,node b)
{
	return a.w<b.w;
}

int find(int x)
{//查找根节点 
	int r=x;
	while(r!=pre[r])
		r=pre[r];
	int i=x,j;
	while(i!=r)
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}

void Merge(int x,int y,int w)
{//判断两个节点是否连通 
	int fx=find(x),fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
		sum+=w;
	}
}

void Kruskal()
{//MST 
	int i,j;
	int count=0;
	for(i=1;i<=n;i++)
		pre[i]=i;
	for(i=1;i<=n;i++)
	{
		for(j=i+1;j<=n;j++)
		{
			if(map[i][j]!=INF)
			{
				edge[count].u=i;
				edge[count].v=j;
				edge[count++].w=map[i][j];
			}
		}
	}
	
	sort(edge,edge+count,cmp);
	for(i=0;i<count;i++)
		Merge(edge[i].u,edge[i].v,edge[i].w);
}

int main()
{
	int i,j;
	char u,v;
	int w,m;
	while(scanf("%d%*c",&n),n)
	{
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				map[i][j]=(i==j? 0:INF);
		
		for(i=1;i<n;i++)
		{
			scanf("%c %d%*c",&u,&m);
			
			while(m--)
			{
				scanf("%c %d%*c",&v,&w);
				map[u-'A'+1][v-'A'+1]=map[v-'A'+1][u-'A'+1]=w;				
			}
		}
		sum=0;
		Kruskal();
		printf("%d\n",sum);
	}
	
	return 0;
}

这个代码只交上了GUN C++ , VC++会超时。

优化代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
struct node{
	int u,v,w;
}edge[105];
int pre[30];
int n,sum,Count;
bool cmp(node a,node b)
{
	return a.w<b.w;
}

int find(int x)
{
	int r=x;
	while(r!=pre[r])
		r=pre[r];
	int i=x,j;
	while(i!=r)
	{
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}

void Kruskal()
{
	int i,j,fx,fy;
	sum=0;
	sort(edge,edge+Count,cmp);
	for(i=0;i<n;i++)
		pre[i]=i;
	
	for(i=0;i<Count;i++)
	{
		fx=find(edge[i].u);
		fy=find(edge[i].v);
		if(fx!=fy)
		{
			sum+=edge[i].w;
			pre[fx]=fy;
		}
	}
}

int main()
{
	int i,j;
	int w,m;
	char u,v;
	while(scanf("%d%*c",&n),n)
	{
		Count=0;
		for(i=1;i<n;i++)
		{
			scanf("%c %d%*c",&u,&m);
			while(m--)
			{
				scanf("%c %d%*c",&v,&w);
				edge[Count].u=u-'A';
				edge[Count].v=v-'A';
				edge[Count++].w=w;
			}
		}
		Kruskal();
		printf("%d\n",sum);
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值