杭电女生赛—Combine String

我总感觉这题我写过题解的,但是为啥不见了呢?

Combine String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 665    Accepted Submission(s): 214


Problem Description
Given three strings a , b and c , your mission is to check whether c is the combine string of a and b .
A string c is said to be the combine string of a and b if and only if c can be broken into two subsequences, when you read them as a string, one equals to a , and the other equals to b .
For example, ``adebcf'' is a combine string of ``abc'' and ``def''.
 

Input
Input file contains several test cases (no more than 20). Process to the end of file.
Each test case contains three strings a , b and c (the length of each string is between 1 and 2000).
 

Output
For each test case, print ``Yes'', if c is a combine string of a and b , otherwise print ``No''.
 

Sample Input
  
  
abc def adebcf abc def abecdf
 

Sample Output
  
  
Yes No

这道题目我还记得六月份我写的时候不是用DP写的,所以会TLE,我直接用递归来暴力,但是如果有的字符是相同的,就出现多种情况,走着走着可能就要回溯到某一步,这就很浪费时间,所以应该采取用空间换时间的动态规划算法。我们可以建立一个二维数组G,G的行 i 列 j 数是代表a的前i个成功匹配到了c,b的前j个成功匹配到了c,合起来就是a和b成功匹配了i+j-1个c字符,最后只要检验这个二维数组G【len_a】【len_b】这个点是否等于1,就知道能不能匹配到了。

代码如下:

#include<stdio.h>
#include<string.h>
int G[2005][2005];
int main()
{
	int len_a,len_b,len_c,i,j;
	char a[2005],b[2005],c[4005];
	while(scanf("%s%s%s",a,b,c)!=EOF)
	{
		len_a=strlen(a);
		len_b=strlen(b);
		len_c=strlen(c);
		if(len_a+len_b!=len_c)
		{
			puts("No");
			continue;
		}
		memset(G,0,sizeof(G));
		G[0][0]=1;
		
		for(i=1;i<=len_a;i++)
		{
			if(a[i-1]==c[i-1]&&G[0][i-1])
				G[0][i]=1;
			else 
				break;
		}
		for(i=1;i<=len_b;i++)
		{
			if(b[i-1]==c[i-1]&&G[i-1][0])
				G[i][0]=1;
			else
				break;
		}
		
		for(i=1;i<=len_b;i++)
		{
			for(j=1;j<=len_a;j++)
			{
				if( (G[i-1][j]&&b[i-1]==c[i+j-1]) || (G[i][j-1]&&a[j-1]==c[i+j-1]))
				{
					G[i][j]=1;
				}
			}
		}
		
		if(G[len_a][len_b])
		{
			printf("Yes\n");
		}
		else
			printf("No\n");
	}
}

题目是不难,但是六月份的时候我没写出来,我当时写了题解后,今天再看一次,发现还是没思路,只好问学长,给了我一个思路,30分钟就写出来了,所以复习错题是很有必要的!


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值