POJ1511 Invitation Cards(spfa模板题)

Invitation Cards
Time Limit:8000MS     Memory Limit:262144KB     64bit IO Format:%lld & %llu

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery. 

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan. 

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees. 

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210

题意:给出一些公交站点和两个站点之间的距离,注意,是单向的线路,要你求出任取一个点,志愿者们出发到其他点然后回来,总花费最少,例如例子1,假定志愿者从1出发,到了2,再从2返回到1,一共是46的花费


这种类型的题目其实是做过的,但是用dijkstra,bellman和floyd都是做不出来的,首先因为内存的问题,他需要开一百万乘以一百万的数组,dijkstra就不行了,其次bellman算法的时间复杂度太高,是O(VE),放在这题目也相当于要运算一百万乘以一百万次,所以都是行不通的,只能求助于SPFA算法了,SPFA算法的时间复杂度是O(KE),k一般小于2,这是个什么概念呢?一百万的数据突然就只需要运算两百万就能过去了,时间上肯定不会超,内存的话只要一个记录边的结构体数组,开个一百万,也足够了,所以这样看起来是很容易就做出来了的,代码如下:

#include<stdio.h>                //spfa基本上要这些头文件
#include<string.h>
#include<queue>
using namespace std;

const int maxn=1e6+5;
const int maxm=1e6+5;
const int INF=0x3f3f3f3f;

int head[maxn],point[maxm<<1],nxt[maxm<<1],val[maxm<<1],size;
int dis[maxn],vis[maxn];

struct node
{
	int start,end;
	int val;
}ori[maxn];

void init()
{
    memset(head,-1,sizeof(head));
    size=0;
}

void add(int a,int b,int v)
{    //有向图只需要前一半
    point[size]=b;
    val[size]=v;
    nxt[size]=head[a];
    head[a]=size++;
/*
    point[size]=a;
    val[size]=v;
    nxt[size]=head[b];
    head[b]=size++;
*/
}

long long spfa(int s,int n)
{
    memset(vis,0,sizeof(vis));
    memset(dis,0x3f,sizeof(dis));
    queue<int>q;
    vis[s]=1;
    dis[s]=0;
    q.push(s);
    while(!q.empty())
	{
        int u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=head[u];~i;i=nxt[i])
		{
            int j=point[i];
            if(dis[j]>dis[u]+val[i])
			{
                dis[j]=dis[u]+val[i];
                if(!vis[j])
				{
                    q.push(j);
                    vis[j]=1;
                }
            }
        }
    }
    long long ans=0;
    for(int i=2;i<=n;i++)
    	ans+=dis[i];
    return ans;
}

int main()
{
	int T;
	int n,m;
	int a,b,c;
	long long sum;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<m;i++)
			scanf("%d%d%d",&ori[i].start,&ori[i].end,&ori[i].val);
		init();
		for(int i=0;i<m;i++)
			add(ori[i].start,ori[i].end,ori[i].val);
		sum=spfa(1,n);
		init();
		for(int i=0;i<m;i++)
			add(ori[i].end,ori[i].start,ori[i].val);
		sum+=spfa(1,n);
		printf("%lld\n",sum);
	}
	return 0;	
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值