中序后序重建二叉树


B - Tree
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


  Tree 

You are to determine the value of the leaf node in a given binary tree that is the terminal node of a path of least value from the root of the binary tree to any leaf. The value of a path is the sum of values of nodes along that path.

Input 

The input file will contain a description of the binary tree given as the inorder and postorder traversal sequences of that tree. Your program will read two line (until end of file) from the input file. The first line will contain the sequence of values associated with an inorder traversal of the tree and the second line will contain the sequence of values associated with a postorder traversal of the tree. All values will be different, greater than zero and less than 10000. You may assume that no binary tree will have more than 10000 nodes or less than 1 node.

Output 

For each tree description you should output the value of the leaf node of a path of least value. In the case of multiple paths of least value you should pick the one with the least value on the terminal node.

Sample Input 

3 2 1 4 5 7 6
3 1 2 5 6 7 4
7 8 11 3 5 16 12 18
8 3 11 7 16 18 12 5
255
255

Sample Output 

1
3
255


#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
using namespace std;
int zx[10010],hx[10010], ans,num,MIN;
struct node
{
    int  a;
    node *left;
    node *right;
};
node *root;
node *rebuild(int *h,int *z,int n)//已知后序中序重建二叉树
{
    int m=h[n-1];
    node *p=new node;
    p->a=m;
    p->left=NULL;
    p->right=NULL;
    int i;
    for( i=0; i<n&&z[i]!=m; i++);
    int ll=i;
    int rl=n-i-1;
    if(ll>0) p->left=rebuild(h,z,ll);
    if(rl>0) p->right=rebuild(h+ll,z+ll+1,rl);
    return p;
}
void dfs(node *p,int num)//深搜
{

    if(p)
        num+=p->a;
    if(p->left==NULL&&p->right==NULL)
    {
        if(num<MIN)
        {
            MIN=num;//搜到叶子结点的和和小于最小值时更新最小值
            ans=p->a;
        }
    }
    if(p->left) dfs(p->left,num);
    if(p->right) dfs(p->right,num);
}
void del(node *p)//删除树
{
    if(p==NULL)
        return ;
    else
    {
        if(p->right!=NULL)
            del(p->right);
        if(p->left!=NULL)
            del(p->left);
    }
    delete(p);
}
int main()
{
    char ch;
    int N=0;
    while(scanf("%d%c",&zx[N++],&ch)!=EOF)
    {
        MIN=0x3fffffff;
        if(ch == '\n')
        {
            for(int i = 0; i < N; i ++)
                scanf("%d", &hx[i]);
            root=rebuild(hx,zx,N);
            dfs(root,0);
            printf("%d\n",ans);
            del(root);
            N=0;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值