hdu 1058 Humble Numbers


H - Humble Numbers
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

 

 

 


 

 

Many of you heard about ugly number. Now we are introducing a new number that is called bubble number.
A number whose only prime factors are 2,3,5 or 7 is called a bubble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 bubble numbers.

 

Write a program to find and print the nth element in this sequence.

 

Input Specification

The input consists of one or more test cases. Each test case consists of one integer n with tex2html_wrap_inline35 . Input is terminated by a value of zero (0) for n.

 

Output Specification

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output. (here humble means bubble)

See http://en.wikipedia.org/wiki/English_numerals#Ordinal_numbers for more explanation of using correct suffix

 

Sample Input

 

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

 

Sample Output

 

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.
 
   
题意:每个数只能由2,3,5,7任意的组合多次使用的乘积得到,换句话一个是只能分解为2,3,5,7,输出第几个这样的数是哪个数字?
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
    long long h[6000];
    int prim[4]= {2,3,5,7};
    h[1]=1;
    for(int i=2; i<=5842; i++)
    {
        h[i]=2000000001;
        for(int k=0; k<4; k++)
        {
            for(int j=i-1; j>=1; j--)  //每次从表中的位置的前一个开始一直到第一个都乘以2,3,5、7更新出出最小的存入表中
            {
                if(h[j]*prim[k]<=h[i-1]) //如果 表中的值计算出的结果小于或者等于
                    break;
                if(h[j]*prim[k]<h[i]) // 更新出最小的存入表中
                    h[i]=h[j]*prim[k];
            }
        }
    }
    int n;
    while(cin>>n&&n!=0)
    {
        printf("The %d",n);
        if(n%10==1&&n%100!=11)
            printf("st");
        else if(n%10==2&&n%100!=12)
            printf("nd");
        else if(n%10==3&&n%100!=13)
            printf("rd");
        else
            printf("th");
        printf(" humble number is %lld.\n",h[n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值