大数相加

题意是 Sample Input
2
1 2
112233445566778899 998877665544332211


Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


#include<iostream>
#include<string>
using namespace std;
int main()
{
	int n;
	cin>>n;
	int nn=1;
	while(n--)
	{
		string add(string x,string y);
	    string x,y;
	    cin>>x>>y;
	    if(n>=1)
	    {
	    	cout<<"Case "<<nn<<":"<<endl;
	    	 cout<<x<<" "<<"+"<<" "<<y<<" "<<"="<<" "<<add(x,y)<<endl;
	    	 cout<<endl;
		}
	   else
	   {
	   	    cout<<"Case "<<nn<<":"<<endl;
	    	cout<<x<<" "<<"+"<<" "<<y<<" "<<"="<<" "<<add(x,y)<<endl;
	   }
	   nn++;
	}
	return 0;
}
string add(string x,string y)
{
	if(x.length()<y.length())
	{
		string temp=x;
		x=y;
		y=temp;
	}
	int g=0;
	for(int i=x.length()-1,j=y.length()-1;i>=0;i--,j--)
	{
		if(j>=0)
		{
			x[i]=char(x[i]+y[j]-'0'+g);
		}
		else
		{
			x[i]=char(x[i]+0);
		}
		if(x[i]-'0'>=10)
		{
			x[i]=char((x[i]-'0')%10+'0');
			g=(x[i]-'0')/10;
		}	
	}
	return x;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值