Pots POJ - 341

Pots POJ - 341

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:
FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.
Input
On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).
Output
The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

bfs最短路径+输出路径的问题。 记录i的值,即为路径。本来用一个short类型的数组记录路径,内存超限。后改为vector记录。还是内存超限。再看看题发现是impossible的情况未讨论。本想限制循环次数,若达到一定次数还不能得到答案,就判为impossible。然后不是时间超限就是内存错误。又改成了标记,过了。

#include<iostream>
#include<queue>
#include<cstring>
#include<vector>
using namespace std;

int a,b,c;
int flag;
bool vis[115][115];//标记 
struct node{
	int x,y;
	int step;
	vector<int>l;//存路径 
};

node bfs()
{
	node cur,next;
	queue<node>q;
	cur.x=cur.y=cur.step=0;//初始化 
	next.x=next.y=next.step=0;
	q.push(cur);
	vis[0][0]=true;
	while(!q.empty())
	{
		cur=q.front();
		q.pop();
     	if(cur.x==c||cur.y==c)
		{
			flag=1;
			return cur;
		}
		for(int i=0;i<6;i++)
		{
			if(i==0)
			{
				next=cur;
				if(cur.x<a)
				{
					next.x=a;
					next.step=cur.step+1;
					next.l.push_back(i);//记录路径 
					if(!vis[next.x][next.y])//判断是否遇到过这种情况,若否,则入队 
					q.push(next);
					vis[next.x][next.y]=true;//标记 
				}
			}
			else if(i==1)
			{
				next=cur;
				if(cur.y<b)
				{
					next.y=b;
					next.step=cur.step+1;
					next.l.push_back(i);
					if(!vis[next.x][next.y])
					q.push(next);
					vis[next.x][next.y]=true;
				}
			}
			else if(i==2)
			{
				next=cur;
				if(cur.x!=0)
				{
					next.x=0;
					next.step=cur.step+1;
					next.l.push_back(i);
					if(!vis[next.x][next.y])
					q.push(next);
					vis[next.x][next.y]=true;
				}
			}
			else if(i==3)
			{
				next=cur;
				if(cur.y!=0)
				{
					next.y=0;
					next.step=cur.step+1;
					next.l.push_back(i);
					if(!vis[next.x][next.y])
					q.push(next);
					vis[next.x][next.y]=true;
				}
			}
			else if(i==4)
			{
				next=cur;
				if(cur.x!=0)
				{
					if(cur.x>=(b-cur.y))
					{
						next.x=next.x-(b-next.y);
						next.y=b;
						next.step=cur.step+1;
						next.l.push_back(i);
						if(!vis[next.x][next.y])
						q.push(next);
						vis[next.x][next.y]=true;
					}
					else{
						next.y=next.y+next.x;
						next.x=0;
						next.step=cur.step+1;
						next.l.push_back(i);
						if(!vis[next.x][next.y])
						q.push(next);
						vis[next.x][next.y]=true;
					}
				}
			}
			else if(i==5)
			{
				next=cur;
				if(next.y!=0)
				{
					if(cur.y>=(a-cur.x))
					{
						next.y=next.y-(a-next.x);
						next.x=a;
						next.step=cur.step+1;
						next.l.push_back(i);
						if(!vis[next.x][next.y])
						q.push(next);
						vis[next.x][next.y]=true;
					}
					else{
						next.x=next.y+next.x;
						next.y=0;
						next.step=cur.step+1;
						next.l.push_back(i);
						if(!vis[next.x][next.y])
						q.push(next);
						vis[next.x][next.y]=true;
					}
				}
			}
		}
	}
	return cur;
}

int main()
{
	cin>>a>>b>>c;
	node ans=bfs();
	if(flag)
	{
		cout<<ans.step<<endl;
		for(int i=0;i<ans.step;i++)
		{
			if(ans.l[i]==0)
			{
				cout<<"FILL(1)"<<endl;
			}
			else if(ans.l[i]==1)
			{
				cout<<"FILL(2)"<<endl;
			}
			else if(ans.l[i]==2)
			{
				cout<<"DROP(1)"<<endl;
			}
			else if(ans.l[i]==3)
			{
				cout<<"DROP(2)"<<endl;
			}
			else if(ans.l[i]==4)
			{
				cout<<"POUR(1,2)"<<endl;
			}
			else if(ans.l[i]==5)
			{
				cout<<"POUR(2,1)"<<endl;
			}
		}
	}
	else{
		cout<<"impossible"<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值