codevs 1230 元素查找(hash)

题目描述 Description

给出n个正整数,然后有m个询问,每个询问一个整数,询问该整数是否在n个正整数中出现过。

输入描述 Input Description

第一行两个整数 n 和m。
第二行n个正整数(1<=n<= 100000)
第三行m个整数(1<=m<=100000)

输出描述 Output Description

一共m行,若出现则输出YES,否则输出NO

样例输入 Sample Input

4 2
2 1 3 4
1 9

样例输出 Sample Output

YES
NO

数据范围及提示 Data Size & Hint

所有数据都不超过10^8

hash思路:给定一个字符串(或数字串)a,模一个数(一般为质数),令x=a%mod,以x为起点,a为终点建立一条边,查询时扫描某一个点的连边即可。

#include<iostream>
using namespace std;
const int maxn=500010;
int n,m,tot,tmp,head[maxn];
struct node
{
    int to;
    int next;
}e[maxn];
int get_hash(int x)
{
    return x%10007;
}
void add_edge(int u,int v)
{
    tot++;
    e[tot].to=v;
    e[tot].next=head[u];
    head[u]=tot;
}
bool find(int u,int v)
{
    for(int i=head[u];i;i=e[i].next)
    if(e[i].to==v)
    return 1;
    return 0;
}
int main()
{
    int x,y;
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        cin>>tmp;
        x=get_hash(tmp);
        add_edge(x,tmp);
    }
    for(int i=1;i<=m;i++)
    {
        cin>>tmp;
        x=get_hash(tmp);
        if(find(x,tmp))
        cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值