Grandpa's Estate
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 11251 | Accepted: 3102 |
Description
Being the only living descendant of his grandfather, Kamran the Believer inherited all of the grandpa's belongings. The most valuable one was a piece of convex polygon shaped farm in the grandpa's birth village. The farm was originally separated from the neighboring farms by a thick rope hooked to some spikes (big nails) placed on the boundary of the polygon. But, when Kamran went to visit his farm, he noticed that the rope and some spikes are missing. Your task is to write a program to help Kamran decide whether the boundary of his farm can be exactly determined only by the remaining spikes.
Input
The first line of the input file contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case contains an integer n (1 <= n <= 1000) which is the number of remaining spikes. Next, there are n lines, one line per spike, each containing a pair of integers which are x and y coordinates of the spike.
Output
There should be one output line per test case containing YES or NO depending on whether the boundary of the farm can be uniquely determined from the input.
Sample Input
1 6 0 0 1 2 3 4 2 0 2 4 5 0
Sample Output
NO
分析:大神的思路 看懂了
”题意:输入一个凸包上的点(没有凸包内部的点,要么是凸包顶点,要么是凸包边上的点),判断这个凸包是否稳定。所谓稳
定就是判断能不能在原有凸包上加点,得到一个更大的凸包,并且这个凸包包含原有凸包上的所有点。
分析:容易知道,当一个凸包稳定时,凸包的每条边上都要有至少三个点,若只有两个点,则可以增加一个点,得到更大的凸
包。这样我们可以求出凸包,在求凸包时把共线的点也加进来,这样我们就判断是否有连续的三点共线即可,具体参见代码。
“
code:
<span style="font-size:18px;">#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <math.h>
using namespace std;
const int N = 40005;
typedef double DIY;
struct Point
{
DIY x,y;
};
Point p[N];
Point stack[N];
Point MinA;
int top;
DIY dist(Point A,Point B)
{
return sqrt((A.x-B.x)*(A.x-B.x)+(A.y-B.y)*(A.y-B.y));
}
DIY cross(Point A,Point B,Point C)
{
return (B.x-A.x)*(C.y-A.y)-(B.y-A.y)*(C.x-A.x);
}
int cmp(const void *a,const void *b)
{
Point *c=(Point *)a;
Point *d=(Point *)b;
DIY k=cross(MinA,*c,*d);
if(k<0||(!k && dist(MinA,*c)>dist(MinA,*d)))
return 1;
return -1;
//这里共线的点按距离从小到大排序
}
void Graham(int n)
{
int i;
for(i=1; i<n; i++)
if(p[i].y<p[0].y||(p[i].y==p[0].y&&p[i].x<p[0].x))
swap(p[i],p[0]);
MinA=p[0];
qsort(p+1,n-1,sizeof(Point),cmp);
//sort(p+1,p+n,cmp);
stack[0]=p[0];
stack[1]=p[1];
top=1;
for(i=2; i<n; i++)
{
//注意这里我们把共线的点也压入凸包里
while(cross(stack[top-1],stack[top],p[i])<0&&top>=1) --top;
stack[++top]=p[i];
}
}
bool Judge()
{
for(int i=1;i<top;i++)
if((cross(stack[i-1],stack[i+1],stack[i]))!=0&&(cross(stack[i],stack[i+2],stack[i+1]))!=0)
return false;
return true;
}
int main()
{
int t,n,i;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%lf%lf",&p[i].x,&p[i].y);
if(n<6)//
{
puts("NO");
continue;
}
Graham(n);
if(Judge()) puts("YES");
else puts("NO");
}
return 0;
}</span>