bnuoj Trick or Treat(三分查找)

Trick or Treat

Time Limit: 10000ms
Memory Limit: 65536KB
64-bit integer IO format:  %lld      Java class name:  Main
Special Judge
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                   
  • Johnny and his friends have decided to spend Halloween night doing the usual candy collection from the households of their village. As the village is too big for a single group to collect the candy from all houses sequentially, Johnny and his friends have decided to split up so that each of them goes to a different house, collects the candy (or wreaks havoc if the residents don't give out candy), and returns to a meeting point arranged in advance.

    There are n houses in the village, the positions of which can be identified with their Cartesian coordinates on the Euclidean plane. Johnny's gang is also made up of n people (including Johnny himself). They have decided to distribute the candy after everybody comes back with their booty. The houses might be far away, but Johnny's interest is in eating the candy as soon as possible.

    Keeping in mind that, because of their response to the hospitality of some villagers, some children might be wanted by the local authorities, they have agreed to fix the meeting point by the river running through the village, which is the line y = 0. Note that there may be houses on both sides of the river, and some of the houses may be houseboats (y = 0). The walking speed of every child is 1 meter per second, and they can move along any direction on the plane.

    At exactly midnight, each child will knock on the door of the house he has chosen, collect the candy instantaneously, and walk back along the shortest route to the meeting point. Tell Johnny at what time he will be able to start eating the candy.

    Input

     Each test case starts with a line indicating the number n of houses ( 1<=n<=50 000). The next n lines describe the positions of the houses; each of these lines contains two floating point numbers x and y ( -200 000 <= xy <= 200 000), the coordinates of a house in meters. All houses are at different positions.

    A blank line follows each case. A line with n = 0 indicates the end of the input; do not write any output for this case.

    Output

    For each test case, print two numbers in a line separated by a space: the coordinate x of the meeting point on the line y = 0 that minimizes the time the last child arrives, and this time itself (measured in seconds after midnight). Your answer should be accurate to within an absolute or relative error of 10-5.

    Sample Input

    2
    1.5 1.5
    3 0
    
    1
    0 0
    
    4
    1 4
    4 4
    -3 3
    2 4
    
    5
    4 7
    -4 0
    7 -6
    -2 4
    8 -5
    
    0

    Sample Output

    1.500000000 1.500000000
    0.000000000 0.000000000
    1.000000000 5.000000000
    3.136363636 7.136363636



    题意从x轴上选择一点 使得给出的各点到改点的最大值最小,时间给的够长可以暴力 但是从样例中可以发现 各点x轴上的一点的距离随着x轴上一点的移动而发生变化 可以观察出 距离函数并非为单调函数 即可以用三分搜索

    code:

    #include<stdio.h>
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    #include<math.h>
    using namespace std;
    const double esp=1e-5;//精度控制在1e-5 -- 1e-10之间 否则 不是WA 就是TLE!!!试过
    struct node{
    double x,y;
    }p[50001];
    int n;
    double dis(node a,node b)
    {
        return sqrt((a.x-b.x)*(a.x-b.x)*1.0+(a.y-b.y)*(a.y-b.y));
    }
    
    double solve(double pos)
    {
        double maxx=-200000;
        node po;
        po.x=pos,po.y=0;
        for(int i=0;i<n;i++)
        {
            double tt=dis(po,p[i]);
            maxx=max(maxx,tt);
        }
        return maxx;
    }
    int main()
    {
        double l,r,ml,mr;
        int i,j;
        while(scanf("%d",&n),n)
        {
            ml=200000;mr=-200000;
            for(i=0;i<n;i++)
            {
                scanf("%lf%lf",&p[i].x,&p[i].y);
                if(ml>p[i].x) ml=p[i].x;
                if(mr<p[i].x) mr=p[i].x;
            }
            while((mr-ml)>esp)
            {
                double mid=(mr-ml)/3;
                l=ml+mid,r=ml+2*mid;
    //            printf("%lf %lf\n",ml,mr);
    //            printf("l=%lf   solve(l)=%lf  r=%lf   solve(r)=%lf\n",l,solve(l),r,solve(r));
                if(solve(l)>=solve(r))ml=l;
                else mr=r;
            }
            printf("%.9lf %.9lf\n",mr,solve(mr));
        }
        return 0;
    }


    • 0
      点赞
    • 2
      收藏
      觉得还不错? 一键收藏
    • 0
      评论

    “相关推荐”对你有帮助么?

    • 非常没帮助
    • 没帮助
    • 一般
    • 有帮助
    • 非常有帮助
    提交
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值