多校

MZL's xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 52    Accepted Submission(s): 42


Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all ( Ai + Aj )( 1i,jn )
The xor of an array B is defined as B1 xor B2 ...xor Bn
 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers: n , m , z , l
A1=0 , Ai=(Ai1m+z) mod l
1m,z,l5105 , n=5105
 

Output
For every test.print the answer.
 

Sample Input
  
  
2 3 5 5 7 6 8 8 9
 

Sample Output
  
  
14 16
思路:当i!=j时 一定存在Ai+Aj 与Aj+Ai 两数的大小相同,相等的两个数异或为0,0余任何数异或为任何数,所以只需要考虑当i==j时即可;

code:

#include<stdio.h>
const int maxx=1000010;
long long a[maxx];
int main()
{
    __int64  cas,n,m,z,l,ans,i;
    scanf("%I64d",&cas);
    while(cas--)
    {
        scanf("%lld%lld%lld%lld",&n,&m,&z,&l);
        a[1]=ans=0;
        for(i=2;i<=n;i++)
            a[i]=(a[i-1]*m+z)%l;

        for(i=2;i<=n;i++)
            ans=ans^(2*a[i]);
        printf("%I64d\n",ans);
    }
}



MZL's chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 36    Accepted Submission(s): 33


Problem Description
MZL define F(X) as the first ionization energy of the chemical element X

Now he get two chemical elements U,V ,given as their atomic number,he wants to compare F(U) and F(V)

It is guaranteed that atomic numbers belongs to the given set: {1,2,3,4,..18,35,36,53,54,85,86}

It is guaranteed the two atomic numbers is either in the same period or in the same group

It is guaranteed that xy
 

Input
There are several test cases

For each test case,there are two numbers u,v ,means the atomic numbers of the two element
 

Output
For each test case,if F(u)>F(v) ,print "FIRST BIGGER",else print"SECOND BIGGER"
 

Sample Input
  
  
1 2 5 3
 

Sample Output
  
  
SECOND BIGGER FIRST BIGGER

code:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    double a[100];
    a[1]=1312.0;a[2]=2372.3;
    a[3]=520.2;a[4]=899.5;a[5]=800.6;a[6]=1086.6;a[7]=1402.3;a[8]=1313.9;a[9]=1681.0;a[10]=2080.7;
    a[11]=495.8;a[12]=737.7;a[13]=577.5;a[14]=786.5;a[15]=1011.8;a[16]=999.6;a[17]=1250.2;a[18]=1520.6;
    a[35]=1139.9;a[36]=1350.8;
    a[53]=1008.4;a[54]=1170.4;
    a[85]=890;a[86]=1037;
    int x,y;
    while(scanf("%d%d",&x,&y)!=EOF)
    {
        if(a[x]>a[y])
            printf("FIRST BIGGER\n");
        else
            printf("SECOND BIGGER\n");

    }
    return 0;
}





MZL's simple problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 129    Accepted Submission(s): 53


Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
The first line contains a number N ( N106 ),representing the number of operations.
Next N line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than 109 .
 

Output
For each operation 3,output a line representing the answer.
 

Sample Input
  
  
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
  
  
3 4

code:

#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t,sum=0,Max=-1e9-7;
    scanf("%d",&t);
    while(t--)
    {
       // cout<<Max;
        int x,y;
        scanf("%d",&x);
        if(x==1)
        {
            scanf("%d",&y);
            Max=max(y,Max);
            sum++;
        }
        else if(x==2)
        {
            if(sum>0)
                sum--;
            if(sum==0)
                Max=-1e9;
        }
        else
        {
            if(sum==0)
                printf("0\n");
            else
                printf("%d\n",Max);
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值