PAT乙级1035

PAT乙级1035

马上读研了,拿pat复习一下吸语言。

题目

根据维基百科的定义:

插入排序是迭代算法,逐一获得输入数据,逐步产生有序的输出序列。每步迭代中,算法从输入序列中取出一元素,将之插入有序序列中正确的位置。如此迭代直到全部元素有序。

归并排序进行如下迭代操作:首先将原始序列看成 N 个只包含 1 个元素的有序子序列,然后每次迭代归并两个相邻的有序子序列,直到最后只剩下 1 个有序的序列。

现给定原始序列和由某排序算法产生的中间序列,请你判断该算法究竟是哪种排序算法?

输入格式:

输入在第一行给出正整数 N (≤100);随后一行给出原始序列的 N 个整数;最后一行给出由某排序算法产生的中间序列。这里假设排序的目标序列是升序。数字间以空格分隔。

输出格式:

首先在第 1 行中输出Insertion Sort表示插入排序、或Merge Sort表示归并排序;然后在第 2 行中输出用该排序算法再迭代一轮的结果序列。题目保证每组测试的结果是唯一的。数字间以空格分隔,且行首尾不得有多余空格。

输入样例 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

输出样例 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

输入样例 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

输出样例 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

错误

编译错误

a.cpp:81:6: error: reference to ‘is_same’ is ambiguous

is_same这个函数也被编译器占用了。。。。。。。。

#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>

/*

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0


10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
*/


using namespace std;

//statement code
int input_array[110];//第一行input
int current_array[110];//第二行input
int insert_array[110][110];
int merge_array[110][110];
int N,i;
int current_insert_step = -1,current_merge_step = -1,max_insert_step,max_merge_step;//第二行的步数、最多的步数



//function section
int robustness_check1(){//robustness function1
	return 0;
}

void print_array(int a[]){
	for(i = 0 ; i < N ; i++){
		printf("%d",a[i]);
		if(i != N-1){
			printf(" ");
		}
	}
}

bool cmp(int a,int b){
	return a < b;
}

void copy_array(int a[] , int b[]){
	
	for(i = 0 ; i < N ; i++){
		a[i] = b[i];
	}
}

int is_same(int a[],int b[]){
	int result = 1;
	for(i = 0 ; i < N ; i++){
		if(a[i] != b[i])
			result = -1;
	}
	return result;
}

void set_insert_array(){
	int temp[110];
	int current_step = 1;
	for(i = 0 ; i < N ; i++){
		temp[i] = input_array[i];
	}
	while(current_step < N){
		for(i = current_step ; i > 0 ; i--){
			if(temp[i] < temp[i-1]){
				int t = temp[i];
				temp[i] = temp[i-1];
				temp[i-1] = t;
			}else
				break;
		}
		copy_array(insert_array[current_step],temp);
		if(is_same(current_array,temp) == 1)
			current_insert_step = current_step;
		current_step++;
	}
	max_insert_step = current_step - 1;//最后一次多加一次
}

void set_merge_array(){
	int temp[110];
	int k = 1;
	int current_step = 1;
	for(i = 0 ; i < N ; i++){
		temp[i] = input_array[i];
	}

	while(k < N){
		int t;
		k*=2;
		if(k >= N)
			sort(temp,temp+N,cmp);
		else{
			for(t = 0 ; t < N ; t += k){
				if(t + k <= N)
					sort(temp+t,temp + t + k,cmp);
				else
					sort(temp+t,temp + N,cmp);
			}
		}
		copy_array(merge_array[current_step],temp);
		if(is_same(current_array,temp) == 1)
			current_merge_step = current_step;
		current_step++;
	}
	max_merge_step = current_step - 1;
}



void print_result(){
	set_insert_array();
	set_merge_array();
	if(current_insert_step != -1){
		printf("Insertion Sort\n");
		print_array(insert_array[current_insert_step+1]);
		return;
	}
	if(current_merge_step != -1){
		printf("Merge Sort\n");
		print_array(merge_array[current_merge_step+1]);		
		return;
	}
	printf("error\n");
	return;
}

int main(){
	//input code
	scanf("%d",&N);
	for(i = 0 ; i < N ;i++){
		int t;
		scanf("%d",&t);
		input_array[i] = t;
	}
	for(i = 0 ; i < N ;i++){
		int t;
		scanf("%d",&t);
		current_array[i] = t;
	}
	//robustness code
	//function code
	print_result();
	return 0;
}

代码

X没有大写。。。。。。

#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>

/*

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
*/

using namespace std;

//statement code
int input_array[110];//第一行input
int current_array[110];//第二行input
int insert_array[110][110];
int merge_array[110][110];
int N,i;
int current_insert_step = -1,current_merge_step = -1,max_insert_step,max_merge_step;//第二行的步数、最多的步数

//function section
int robustness_check1(){//robustness function1
	return 0;
}
void print_array(int a[]){
	for(i = 0 ; i < N ; i++){
		printf("%d",a[i]);
		if(i != N-1){
			printf(" ");
		}
	}
}
bool cmp(int a,int b){
	return a < b;
}
void copy_array(int a[] , int b[]){
	
	for(i = 0 ; i < N ; i++){
		a[i] = b[i];
	}
}
int issame(int a[],int b[]){
	int result = 1;
	for(i = 0 ; i < N ; i++){
		if(a[i] != b[i])
			result = -1;
	}
	return result;
}
void set_insert_array(){
	int temp[110];
	int current_step = 1;
	for(i = 0 ; i < N ; i++){
		temp[i] = input_array[i];
	}
	while(current_step < N){
		for(i = current_step ; i > 0 ; i--){
			if(temp[i] < temp[i-1]){
				int t = temp[i];
				temp[i] = temp[i-1];
				temp[i-1] = t;
			}else
				break;
		}
		copy_array(insert_array[current_step],temp);
		if(issame(current_array,temp) == 1)
			current_insert_step = current_step;
		current_step++;
	}
	max_insert_step = current_step - 1;//最后一次多加一次
}
void set_merge_array(){
	int temp[110];
	int k = 1;
	int current_step = 1;
	for(i = 0 ; i < N ; i++){
		temp[i] = input_array[i];
	}

	while(k < N){
		int t;
		k*=2;
		if(k >= N)
			sort(temp,temp+N,cmp);
		else{
			for(t = 0 ; t < N ; t += k){
				if(t + k <= N)
					sort(temp+t,temp + t + k,cmp);
				else
					sort(temp+t,temp + N,cmp);
			}
		}
		copy_array(merge_array[current_step],temp);
		if(issame(current_array,temp) == 1)
			current_merge_step = current_step;
		current_step++;
	}
	max_merge_step = current_step - 1;
}
void print_result(){
	set_insert_array();
	set_merge_array();
	if(current_insert_step != -1){
		printf("Insertion Sort\n");
		print_array(insert_array[current_insert_step+1]);
		return;
	}
	if(current_merge_step != -1){
		printf("Merge Sort\n");
		print_array(merge_array[current_merge_step+1]);		
		return;
	}
	printf("error\n");
	return;
}
int main(){
	//input code
	scanf("%d",&N);
	for(i = 0 ; i < N ;i++){
		int t;
		scanf("%d",&t);
		input_array[i] = t;
	}
	for(i = 0 ; i < N ;i++){
		int t;
		scanf("%d",&t);
		current_array[i] = t;
	}
	//robustness code
	//function code
	print_result();
	return 0;
}

总结

  • 算法有点生疏了,看着样例想了一会才想起来。
  • 这道题还算比较简单,25分可能是给在了算法的难度上了。
  • is_same()函数也被使用了。。。。。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值