hdoj 2717 Catch That Cow

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9375    Accepted Submission(s): 2939


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
  
  
5 17
 

Sample Output
  
  
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 


bfs

代码:

 

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct record
{
	int start;
	int time;
};
int n,k;
int vis[201000];  //第一次开101000,runtime error,果断换成201000; 
int d[3]={-1,1,0};
queue<record>q;
void bfs()
{
	record e,temp;
	while(!q.empty())
	{
		q.pop();
	}
	e.start=n;
	e.time=0;
	vis[e.start]=1;
	q.push(e);
    while(!q.empty())
    {
    	e=q.front();
    	q.pop();
    	for(int i=0;i<3;i++)
    	{
		    temp=e;
    		if(d[i]!=0)
    		{
    			temp.start+=d[i];
    			temp.time=e.time+1;
			}
			else
			{
				temp.start*=2;
				temp.time=e.time+1;
			}
			if(vis[temp.start]||temp.start<0||temp.start>100000)
			{
				continue;
			}
			vis[temp.start]=1;
			if(temp.start==k)
			{
				printf("%d\n",temp.time);
				return ;
			}
    		q.push(temp);
		}
	}
}
int main()
{
	while(scanf("%d%d",&n,&k)!=EOF)
	{
		if(n==k)
		{
			printf("0\n");
			continue;
		}
		memset(vis,0,sizeof(vis));
		bfs();
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值