poj 3468 A Simple Problem with Integers 【线段树成段更新 + 区间求和】

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 82324 Accepted: 25485
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


代码:


#include<stdio.h>
#include<string.h>
#define M 100010
long long add[M*4];
long long sum[M*4];
char s[3];
void pushup(int node)
{
	sum[node]=sum[node*2]+sum[node*2+1];
}
void pushdown(int node,int m)
{
	if(add[node])
	{
		add[node*2]+=add[node];
		add[node*2+1]+=add[node];
		sum[node*2]+=add[node]*(m-(m/2));
		sum[node*2+1]+=add[node]*(m/2);
		add[node]=0;
	}
}
void build(int l,int r,int node)
{
	add[node]=0;
	if(l==r)
	{
		scanf("%lld",&sum[node]);
		return ;
	}
	int mid=(l+r)/2;
	build(l,mid,node*2);
	build(mid+1,r,node*2+1);
	pushup(node);
}
long long query(int L,int R,int l,int r,int node)
{
	if(L<=l&&R>=r)
	{
		return sum[node];
	}
	pushdown(node,r-l+1);
	int mid=(l+r)/2;
	long long ans=0;
	if(L<=mid)
	ans+=query(L,R,l,mid,node*2);
	if(R>mid)
	ans+=query(L,R,mid+1,r,node*2+1);
	return ans;
}
void update(int L,int R,int v,int l,int r,int node)
{
	if(L<=l&&R>=r)
	{
		add[node]+=v;
		sum[node]+=v*(r-l+1);
		return ;
	}
	pushdown(node,r-l+1);
	int mid=(l+r)/2;
	if(L<=mid)
	update(L,R,v,l,mid,node*2);
	if(R>mid)
	update(L,R,v,mid+1,r,node*2+1);
	pushup(node);
}
int main()
{
	int n,q;
	int i,a,b,c;
	while(scanf("%d%d",&n,&q)!=EOF)
	{
		build(1,n,1);
		while(q--)
		{
			scanf("%s",s);
			if(s[0]=='Q')
			{
				scanf("%d%d",&a,&b);
				printf("%lld\n",query(a,b,1,n,1));
			}
			if(s[0]=='C')
			{
				scanf("%d%d%d",&a,&b,&c);
				update(a,b,c,1,n,1);
			}
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值