计蒜客————Folding

  •  30.64%
  •  2000ms
  •  262144K


As you can remember, Alex is fond of origami. She switched from squares to rectangles, and rectangles are much more difficult to master. Her main interest is to determine what is the minimum possible number of folds required to transform ×rectangle to × one. The result of each fold should also be rectangular, so it is only allowed to make folds that are parallel to the sides of the rectangle.

Help Alex and write a program that determines the minimum required number of folds.

Input

The first line of the input contains two integers Wand — the initial rectangle dimensions. The second line contains two more integers and — the target rectangle dimensions (1 ≤ W, H, w, h ≤ 10^9109).

Output

Output a single integer — the minimum required number of folds to transform the initial rectangle to the target one.

If the required transformation is not possible, output 1. 

样例输入1
2 7
2 2
样例输出1
2
样例输入2
10 6
4 8
样例输出2
2
样例输入3
5 5
1 6
样例输出3
-1
上面所给矩形折叠成下边所给矩形的最小折叠次数..模拟一下就好.
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int func2(int x1,int x2){
    if(x2==x1) return 0;
    for(int i=1;;i++){
        x2*=2;
        if(x2>=x1) return i;
    }
}
int func1(int x1,int y1,int x2,int y2) {
    if(x1<x2||y1<y2) return -1;
    return func2(x1,x2)+func2(y1,y2);
}
int main() {
    int x1,x2,y1,y2;
    while(~scanf("%d%d%d%d",&x1,&y1,&x2,&y2)){
        int t1=func1(x1,y1,x2,y2),t2=func1(x1,y1,y2,x2);
        if(t1==-1||t2==-1)
            printf("%d\n",max(t1,t2));
        else printf("%d\n",min(t1,t2));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值