KMP之Power Strings

Power Strings

 

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
汉化:

给定两个字符串a和b,我们定义a * b是它们的连接。 例如,如果a =“abc”和b =“def”,那么a * b =“abcdef”。 如果我们将连接看作是乘法,则用正常的方式定义非负整数的指数:a ^ 0 =“”(空字符串)和a ^(n + 1)= a *(a ^ n)。
输入
每个测试用例都是一行代表s的输入,一串可打印的字符。 s的长度至少为1,不会超过100万字符。 在最后一个测试用例之后包含句点的一行。
产量
对于每一个s,你应该打印出最大的n,这样对于某个字符串a,s = a ^ n。
示例输入
A B C D
AAAA
ABABAB

示例输出
1
4
3
提示
这个问题有巨大的输入,使用scanf而不是cin来避免超时。

其实很简单啦,都不需要KMP函数==不过用到了next数组的几个应用。具体见注释,AC代码如下:

#include "cstdio"
#include "cstring"
using namespace std;

char s[1000005];
int ne[1000001];
void GetNext(char *a)
{
     int len = strlen(a);
     int i = 0, j = -1;
     ne[0] = -1;
     while(i < len)
     {
          if(j == -1 || a[i] == a[j])
          {
               ne[++i] = ++j;
          }
          else j = ne[j];
     }
}

int main()
{
     while(scanf("%s", s) && s[0] != '.')
     {
          GetNext(s);
          int L = strlen(s);
          if(L % (L - ne[L]) == 0)///如果第i-1位为结尾的循环必定有 i % (i - Next[i]) == 0
               printf("%d\n", L/(L - ne[L]));///0~i-1共有i个字符,i / (i - Next[i])就是循环次数。
          else
               printf("1\n");
     }
     return 0;
}///这道题简单在从头开始的前缀

  • 1
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值