Android 开发 ------------- Unable to resolve target 'android-19'

重新装完Ecplise+ATD+Android SDK 在Ecplise工作空间导入之前写过的Android项目会出现错误,大部分是SDK 版本不符,如下错误提示:
Error:Unable to resolve target android-19

如图:



解决办法:修改工程目录下的project.properties文件里的内容target=android-19   数字改成你机器里装过的android SDK版本就可以了。


如图:



附:
使用高版本的SDK后再导入以前用低版本的project时,会遇到一些兼容性的问题。
(1)Unable to resolve target android-5
因为本机中现在使用的是2.1的SDK,API的版本是7;而导入的工程使用的是2.0开发的,其API版本是5。
需要将project.properties中的target=android-5改为target=android-7就好了。
但要注意,也要同步将AndroidManifest.xml中的<uses-sdk android:minSdkVersion="5" />也要改一下,否则编译中会警告提示使用的版本过低。
(2)以上完成后,编译中又出现一个新的错误:Conversion to Dalvik format failed with error 1
这个与加载的SDK有关,通过“右键选择工程build path -> configure build path... -> library发现导入的JARs中除了一个Android 2.1-update1外还有一个同路径下的文件夹item,将其移除,clean一下再编译就没问题了。

展开阅读全文

没有更多推荐了,返回首页