POJ3020 Antenna Placement【二分图匹配问题——最小边覆盖】

Description

The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them.

Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered?

Input

On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space.

Output

For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

Sample Input

2
7 9
ooo**oooo
**oo*ooo*
o*oo**o**
ooooooooo
*******oo
o*o*oo*oo
*******oo
10 1
*
*
*
o
*
*
*
*
*
*

Sample Output

17
5

解题思路

题目大意:*--代表城市,o--代表空地

给城市安装无线网,一个无线网最多可以覆盖两座城市,问覆盖所有城市最少要用多少无线。

思路: 这是一个最小路径覆盖问题。因为最多覆盖两个城市,即相邻城市才匹配。最小路径覆盖=总节点数-最大匹配数。建图时是双向的,所以最大匹配数/2。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<algorithm>
using namespace std;

int n, m;
vector<int> G[1000];
int map[50][50], match[510], vis[510];
int mov[4][2] = { {0,1},{0,-1},{-1,0},{1,0} };
char s[50][50];
int cnt = 0;

int dfs(int x)
{
	for (int i = 0; i < G[x].size(); ++i)
	{
		int v = G[x][i];
		if(!vis[v])
		{
			vis[v]=1;
			if (match[v] == -1 || dfs(match[v]))
			{
				match[v]=x;
				return 1;
			}
		}
	}
	return 0;
}

int Hungary()
{
	memset(match,-1,sizeof(match));
	int ans=0;
	for(int i = 0;i<cnt;++i)
	{
		memset(vis, 0, sizeof(vis));
		if (dfs(i))
			ans++;
	}
	return ans;
}

int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		for(int i = 0;i<=1000;++i) G[i].clear();
		scanf("%d%d", &n, &m);
		cnt = 0;
		for (int i = 0; i < n; i++)
		{
			scanf("%s", s[i]);
		}
		for (int i = 0; i < n; i++)
			for (int j = 0; j < m; j++)
				if (s[i][j] == '*')
					map[i][j] = cnt++;
		for (int i = 0; i < n; i++)
		{
			for (int j = 0; j < m; j++)
			{
				if (s[i][j] == 'o')
					continue;
				int u = map[i][j];
				for (int k = 0; k < 4; k++)
				{
					int x = i + mov[k][0];
					int y = j + mov[k][1];
					if (x >= 0 && x < n&&y >= 0 && y < m&&s[x][y] == '*')
					{
						int v = map[x][y];
						G[u].push_back(v);
						G[v].push_back(u);
					}
				}
			}
		}
		int ans = Hungary();
		printf("%d\n", (cnt - ans / 2));
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值