2017 Multi-University Training Contest - Team 3

1008 RXD and math

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 524288/524288 K (Java/Others)

Problem Description:

RXD is a good mathematician.
One day he wants to calculate:
∑i=1nkμ2(i)×⌊nki−−−√⌋
output the answer module 10^9+7.
1≤n,k≤10^18
μ(n)=1(n=1)μ(n)=(−1)k(n=p1p2…pk)μ(n)=0(otherwise)
p1,p2,p3…pk are different prime numbers

Input

There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k.

Output

For each test case, output “Case #x: y”, which means the test case number and the answer.

Sample Input

10 10

Sample Output

Case #1: 999999937

#include <stdio.h>
int PowerMod(long long a, long long b){
    int ans = 1;
    a = a % 1000000007;
    while(b>0){
    if(b % 2 == 1)
        ans = (ans * a) % 1000000007;
        b = b/2;
        a = (a * a) % 1000000007;
    }    
    return ans;
}
int main (){
    long long n, k;
    int i;
    for(i = 1;scanf("%I64d%I64d", &n, &k)!=EOF;i++){
        printf("Case #%d: %d\n", i, PowerMod(n, k));
    }
    return 0;
} 

1011RXD’s date

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 524288/524288 K (Java/Others)

Problem Description

As we all know that RXD is a life winner, therefore he always goes out, dating with his female friends.
Nevertheless, it is a pity that his female friends don’t like extremely hot temperature. Due to this fact, they would not come out if it is higher than 35 degrees.
RXD is omni-potent, so he could precisely predict the temperature in the next t days, but he is poor in counting.
He wants to know, how many days are there in the next t days, in which he could go out and date with his female friends.

Input

There is only one test case.
The first line consists of one integer t.
The second line consists of t integers ci which means the temperature in the next t days.
1≤t≤1000
0≤ci≤50

Output

Output an integer which means the answer.

Sample Input

5
33 34 35 36 37

Sample Output

3

#include <stdio.h>
int main (){
    int t, c;
    while(~scanf("%d", &t)){
        int s = 0;
        while(t--){
            scanf("%d", &c);
            if(c <= 35){
                s++;
            } 
        }
        printf("%d\n", s) ;
    }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值