杭电6318 Swaps and Inversions

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

 

 

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

 

 

Output

For every test case, a single integer representing minimum money to pay.

 

 

Sample Input

 

3 233 666

1 2 3

3 1 666

3 2 1

 

 

Sample Output

 

0 3

 

 

Source

2018 Multi-University Training Contest 2

 

题意就是让一个序列有序最少需要多少钱,有两种方式,一种是随意换花费x元,另一种是在交换前花费y元来交换相邻的两个元素,开始以为是dp,其实就是求逆序列的个数,所以就可以用归并排序,求完之后比较x和y的大小,求出最少花费。

 

 

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
#define N 100005
using namespace std;
int a[N], b[N];
int n, x, y;
long long guibing(int l, int m, int r)//归并排序
{
    int i = l; int j = m + 1;
    int k = 0;
    long long int s = 0;
    while (i <= m && j <= r)
    {
        if (a[i] <= a[j])
        {
            b[k++] = a[i++];
        }
        else
        {
            s += (m - i + 1);//求交换次数
            b[k++] = a[j++];
        }
    }
    while (i <= m)
    {
        b[k++] = a[i++];
    }
    while (j <= r)
    {
        b[k++] = a[j++];
    }
    for (int g = 0; g < k; g++)
    {
        a[l + g] = b[g];
    }
    return s;
}
long long int zz(int l, int r)
{
    long long ans = 0;
    if (l < r)
    {
        int m = (l + r) >> 1;
        ans += zz(l, m);
        ans += zz(m + 1, r);
        ans += guibing(l, m, r);
    }
    return ans;
}
int main()
{
    
    while (~scanf("%d%d%d", &n, &x, &y))
    {
        for (int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        long long ans = zz(1, n);
        if (x > y)
            ans *= y;
        else ans *= x;
        printf("%lld\n", ans);

    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值