HUD6335 Problem D. Nothing is Impossible

Problem Description

m students, including Kazari, will take an exam tomorrow.
The paper consists of exactly n problems, the i-th problem contains ai correct answers and bi incorrect answers, i.e. the i-th problem contains ai+bi candidates in total.
Each student should choose exactly one candidate as answer for each problem. If the answer to a certain problem is correct, then the student will get one point. The student who gets the most points wins.
Students only know the structure of the paper, but they are able to talk with each other during the exam. They decide to choose a subset S of all n problems, and they will only be able to submit answers on these problems.
They want to know the maximum size of S that the winner among them will solve all the problems in S if they take the optimal strategy.


For sample 1, students can choose S={1},and we need at least 4 students to guarantee the winner solve the only problem.

For sample 2, students can choose S={1,2,3}, and we need at least 24 students to guarantee the winner solve these three problems, but if |S|=4, we need at least 96 students, which is more than 50.

 

 

Input

The first line of the input contains an integer T (1≤T≤100) denoting the number of test cases.
Each test case starts with two integers n,m (1≤n≤100,1≤m≤109), denoting the number of problems and the number of students. Each of next n lines contains two integers ai,bi (1≤bi≤100,ai=1), indicating the number of correct answers and the number of incorrect answers of the i-th problem.

 

 

Output

For each test case, print an integer denoting the maximum size of S.

 

 

Sample Input

 

2 3 5 1 3 1 3 1 3 5 50 1 1 1 3 1 2 1 3 1 5

 

 

Sample Output

 

1 3

 

 

Source

2018 Multi-University Training Contest 4

 

 

这个题就是给你一道题正确和错误答案的个数为a和b,和学生的数量,输出能做对题得到数量,要想绝对做对一道题,必须要有b+1个人去做,才能绝对做对,所以把题目按照绝对做对所需要的人数从小到大排序,以使做对的题目最多。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
struct node
{
    int x,y,c;
}a[110];
int cmp(node a,node b)
{
    return a.c<b.c;
}
int main()
{
    int t,n,m,ans;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            a[i].c=a[i].y+1;
        }
        sort(a,a+n,cmp);
        ans=0;
        for(int i=0; i<n; i++)
        {
            if(m>a[i].y)
            {
                ans++;
                m/=a[i].c;
            }
            else
            {
                break;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值