【HDU1018】Big Number - 求n!的位数

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29918    Accepted Submission(s): 13784


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
  
  
2 10 20
 

Sample Output
  
  
7 19
 

Source
 









第一种是暴力的解法,注意,不是本质的暴力,只是相对的暴力:

这题要求n的阶乘的位数,如果n较大时,n的阶乘必将是一个很大的数,题中说1<=n<10000000,当n=10000000时可以说n的阶乘将是一个非常巨大的数字,对于处理大数的问题,我们一般用字符串,这题当n取最大值时,就是一千万个数字相乘的积,太大了,就算保存在字符串中都有一点困难,而且一千万个数字相乘是会涉及到大数的乘法,大数的乘法是比较耗时的,就算计算出结果一般也会超时。这让我们不得不抛弃这种直接的方法。

在这之前,我们必须要知道一个知识,任意一个正整数a的位数等于(int)log10(a) + 1;为什么呢?下面给大家推导一下:

对于任意一个给定的正整数a,假设10^(x-1)<=a<10^x,那么显然a的位数为x位,又因为:

log10(10^(x-1))<=log10(a)<(log10(10^x));

即x-1<=log10(a)<x;

则(int)log10(a)=x-1,

即(int)log10(a)+1=x;

即a的位数是(int)log10(a)+1;

我们知道了一个正整数a的位数等于(int)log10(a) + 1,现在来求n的阶乘的位数:

假设A=n!=1*2*3*......*n,那么我们要求的就是(int)log10(A)+1,而:

log10(A)=log10(1*2*3*......n)  

=(int)(log10(1)+log10(2)+log10(3)+......+log10(n)) + 1

再想一下,这题是要求n的阶乘的位数,而n的阶乘是n个数的乘积,那么要是我们能把这个问题分解就好了

现在我们终于找到方法,问题解决了,我们将求n的阶乘的位数分解成了求n个数对10取对数的和,并且对于其中任意一个数,都在正常的数字范围之类。

总结一下:n的阶乘的位数等于:

(int)(log10(1)+log10(2)+log10(3)+......+log10(n)) + 1

代码如下:

#include<cstdio>
#include<cmath>
using namespace std;
  
int main()
{
  int t,num,i;
  double result;
  scanf("%d",&t);
      while(t--)
    {
        scanf("%d",&num);
        result=1;
        for(i=1;i<=num;++i)
            result+=log10(double(i));
        printf("%d\n",int(result));
    }
    return 0;
}






第二种:
Stirling定理:                      

                                              

即:n! = sqrt(2*π*n) * ((n/e)^n)
得到公式 log10(n!) = log10(sqrt(2 * pi * n)) + n * log10(n / e) + 1

代码如下:

#include<cstdio> 
#include<cmath> 
const double PI=acos(-1.0),e=exp(1.0); 
int main() 
{ 
    int t,n;
    scanf("%d",&t);
    while(t--) 
    {
        scanf("%d",&n); 
        printf("%d\n",(int)(log10(sqrt(2*PI*n))+n*log10(n/e))+1); 
    }
    return 0; 
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值